summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/zxing-cpp')
-rw-r--r--media-libs/zxing-cpp/Manifest1
-rw-r--r--media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch43
-rw-r--r--media-libs/zxing-cpp/zxing-cpp-1.4.0.ebuild28
3 files changed, 0 insertions, 72 deletions
diff --git a/media-libs/zxing-cpp/Manifest b/media-libs/zxing-cpp/Manifest
index 7fb1cf7c9f17..e9f6df0ca556 100644
--- a/media-libs/zxing-cpp/Manifest
+++ b/media-libs/zxing-cpp/Manifest
@@ -1,2 +1 @@
-DIST zxing-cpp-1.4.0.tar.gz 1018225 BLAKE2B 98b6badfe0ddfa39650eb4fbfc02bc01f5237cdd5edfafd7b88067997a22caa2e64d067328b534c439d7d89fef5b6d48acf4bc29389142b332123b477f3e3dde SHA512 05c5b9282f13b76fa0897b21e5b73cb7df0c52e62f1a2d9760fe774aa0378fde97f5f9896690b65b28b4b96ba6ad2703bed53ffaf9d3784636d29cbe860d4bad
DIST zxing-cpp-2.0.0.tar.gz 856413 BLAKE2B 8069d3e39a7ddf99510777df477a5e3503e5eead7adcbf175123ab59de47c3da75bb8187533dad552a07b1475756ff3981d30eaa3e8088c5c9b991e22a7127bd SHA512 fa22164f834a42194eafd0d3e9c09d953233c69843ac6e79c8d6513314be28d8082382b436c379368e687e0eed05cb5e566d2893ec6eb29233a36643904ae083
diff --git a/media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch b/media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch
deleted file mode 100644
index 2a85252f5439..000000000000
--- a/media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 4159a44bdc785b27013bc6be1d32b2e442c73b74 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Thu, 14 Jul 2022 12:04:27 +0200
-Subject: [PATCH] Add INSTALL_PRIVATE_HEADERS switch to unbreak LibreOffice
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt | 1 +
- core/CMakeLists.txt | 6 ++++++
- 2 files changed, 7 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e947ce8d..2e41e773 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -9,6 +9,7 @@ option (BUILD_BLACKBOX_TESTS "Build the black box reader/writer tests" OFF)
- option (BUILD_UNIT_TESTS "Build the unit tests (don't enable for production builds)" OFF)
- option (BUILD_PYTHON_MODULE "Build the python module" OFF)
- set(BUILD_DEPENDENCIES "AUTO" CACHE STRING "Fetch from github or use locally installed (AUTO/GITHUB/LOCAL)")
-+option (INSTALL_PRIVATE_HEADERS "Install (some) private headers to unbreak (some) revdeps broken by 1.4.0 cleanup" OFF)
-
- if (WIN32)
- option (BUILD_SHARED_LIBS "Build and link as shared library" OFF)
-diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
-index 7382bcae..575e696b 100644
---- a/core/CMakeLists.txt
-+++ b/core/CMakeLists.txt
-@@ -174,6 +174,12 @@ if (BUILD_WRITERS)
- )
- endif()
- # end of public header set
-+if (INSTALL_PRIVATE_HEADERS)
-+ set (PUBLIC_HEADERS ${PUBLIC_HEADERS}
-+ src/BitArray.h
-+ )
-+endif()
-+# end of 'private' public header set
-
- set (AZTEC_FILES
- )
---
-2.35.1
-
diff --git a/media-libs/zxing-cpp/zxing-cpp-1.4.0.ebuild b/media-libs/zxing-cpp/zxing-cpp-1.4.0.ebuild
deleted file mode 100644
index d4d127e000be..000000000000
--- a/media-libs/zxing-cpp/zxing-cpp-1.4.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="C++ Multi-format 1D/2D barcode image processing library"
-HOMEPAGE="https://github.com/nu-book/zxing-cpp"
-SRC_URI="https://github.com/nu-book/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/1.4"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-IUSE=""
-
-# Downstream patch until revdeps like LibreOffice are fixed
-PATCHES=( "${FILESDIR}/${P}-install-required-private-headers.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DINSTALL_PRIVATE_HEADERS=ON # required by LibreOffice as of 7.3.5.1
- -DBUILD_EXAMPLES=OFF # nothing is installed
- -DBUILD_BLACKBOX_TESTS=OFF # FIXME: FetchContent.cmake module usage
- -DBUILD_UNIT_TESTS=OFF # for both tests options. no thanks. bug #793173
- )
- cmake_src_configure
-}