summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-8.2.1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 263a25b42e96..930c81e8bdd7 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -1,3 +1,4 @@
DIST harfbuzz-8.0.1.tar.xz 18792332 BLAKE2B e69305e5cddee2f9a928ab38b6904cc3e6fbafb319ad268047178667639a2a361576051a9a6443352b51adca47bb8998ca5c533afe12eac456c3170e171c1839 SHA512 e1292f059b07a5aa2f3fbf345b893209cac895c461b4abf30b8b76bcd03c79dd09f911450293403070e1a0bb08496a7f37693ba5a62a9d423dd6ba55e744444d
DIST harfbuzz-8.1.1.tar.xz 18820088 BLAKE2B 341603e50aec5294eb16fb431975304ee9badce5588d726c5ccbcf9e38878581c4bbf2e09f27c3d401da52c93121702f220cd207792448af66a9f23830df9114 SHA512 74416c6cf78751721112fe551a47600b9b85d6865f38b155c0e432e757a175ac127baeeaa16bfe6d62510e00f9def8950f0c836545d1847a924b478c51e43b0c
DIST harfbuzz-8.2.0.tar.xz 18892496 BLAKE2B a7755f9ee2784fa32ad9ecd74543010ca48be2adfc76612a3dcb73fb8a168d87db3cb69b574c4529a8233325b9d9c9ebd370eb0de0efed165fdba3f997451bf2 SHA512 ac85bea2e3a9693b656c05faaf96720d73e6453d201f2ad5c849d7069e2f597926ba3d8cd63d9e71dda4ede9ce6bae2baebb46557699168abb03fccc3d8085df
+DIST harfbuzz-8.2.1.tar.xz 18889168 BLAKE2B b6aae8806a1d4708474f66f508a1dcecb984205ba58f639a4b7dcf19f07ec4800569363a8ef812419de2d72b0a1f6ce7e31c22c588176066d817ca761836c22b SHA512 8f4aeb5528cb4f74facda89eb9828ccf491d577450ccdd71c331c943edf56303fa73a077d6b620687ae1ba21564aa02e202dbae98b77ac0947bc45e044c05f67
diff --git a/media-libs/harfbuzz/harfbuzz-8.2.1.ebuild b/media-libs/harfbuzz/harfbuzz-8.2.1.ebuild
new file mode 100644
index 000000000000..c114ab1668f9
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-8.2.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit flag-o-matic meson-multilib python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/harfbuzz/harfbuzz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/harfbuzz/harfbuzz/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+# 0.9.18 introduced the harfbuzz-icu split; bug #472416
+# 3.0.0 dropped some unstable APIs; bug #813705
+# 6.0.0 changed libharfbuzz-subset.so ABI
+SLOT="0/6.0.0"
+
+IUSE="+cairo debug doc experimental +glib +graphite icu +introspection test +truetype"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:=[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-util/glib-utils )
+"
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ # bug #726120
+ sed -i \
+ -e '/tests\/macos\.tests/d' \
+ test/shape/data/in-house/Makefile.sources \
+ || die
+
+ # bug #790359
+ filter-flags -fexceptions -fthreadsafe-statics
+
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+
+ # bug #762415
+ local pyscript
+ for pyscript in $(find -type f -name "*.py") ; do
+ python_fix_shebang -q "${pyscript}"
+ done
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for introspection, bug #535852
+ local emesonargs=(
+ -Dcoretext=disabled
+ -Dchafa=disabled
+ -Dwasm=disabled
+
+ $(meson_feature cairo)
+ $(meson_feature glib)
+ $(meson_feature graphite graphite2)
+ $(meson_feature icu)
+ $(meson_feature introspection gobject)
+ $(meson_feature test tests)
+ $(meson_feature truetype freetype)
+
+ $(meson_native_use_feature doc docs)
+ $(meson_native_use_feature introspection)
+ # Breaks building tests..
+ #$(meson_native_use_feature utilities)
+
+ $(meson_use experimental experimental_api)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_test() {
+ # harfbuzz:src / check-static-inits times out on hppa
+ meson_src_test --timeout-multiplier 5
+}