summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-8.3.0.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 2253ed2393d7..97732a586701 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -1,3 +1,4 @@
DIST harfbuzz-8.2.0.tar.xz 18892496 BLAKE2B a7755f9ee2784fa32ad9ecd74543010ca48be2adfc76612a3dcb73fb8a168d87db3cb69b574c4529a8233325b9d9c9ebd370eb0de0efed165fdba3f997451bf2 SHA512 ac85bea2e3a9693b656c05faaf96720d73e6453d201f2ad5c849d7069e2f597926ba3d8cd63d9e71dda4ede9ce6bae2baebb46557699168abb03fccc3d8085df
DIST harfbuzz-8.2.1.tar.xz 18889168 BLAKE2B b6aae8806a1d4708474f66f508a1dcecb984205ba58f639a4b7dcf19f07ec4800569363a8ef812419de2d72b0a1f6ce7e31c22c588176066d817ca761836c22b SHA512 8f4aeb5528cb4f74facda89eb9828ccf491d577450ccdd71c331c943edf56303fa73a077d6b620687ae1ba21564aa02e202dbae98b77ac0947bc45e044c05f67
DIST harfbuzz-8.2.2.tar.xz 18905228 BLAKE2B 5a26aa802b6e1afec734e59a9c280b4d336bb8ad72e0fbe6687237c150faa4d10fb2ae956b58394d7f6a2d1b97e6c91cd597a9b5146dcc3d2841d18d76611ec5 SHA512 90415798d57d8a10b7fa61d3116a64533361c380aa5b0b477ca38cb2aaf411db80dc28d64e077fd5512708143ec122cb3c5eb5dbdf7f97ed5643b0ee4c42ba23
+DIST harfbuzz-8.3.0.tar.xz 19002808 BLAKE2B 3749d2ff7955e135cf0d740bf6fe8b5c20a6bbf171480a29e6ae14fde8c26e1457506278b8c66e3b9630cbeb006874c19075c784a575e490c41297274a27fe59 SHA512 6b8753c0b55d34a1a46a64466b9b0de8bc4748c42b29fa9463616a5f48db08ceb4a80cce416e10861778b98dc96d0638d9dd8d7204e404662154f419f3f61f21
diff --git a/media-libs/harfbuzz/harfbuzz-8.3.0.ebuild b/media-libs/harfbuzz/harfbuzz-8.3.0.ebuild
new file mode 100644
index 000000000000..c114ab1668f9
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-8.3.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit flag-o-matic meson-multilib python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/harfbuzz/harfbuzz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/harfbuzz/harfbuzz/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+# 0.9.18 introduced the harfbuzz-icu split; bug #472416
+# 3.0.0 dropped some unstable APIs; bug #813705
+# 6.0.0 changed libharfbuzz-subset.so ABI
+SLOT="0/6.0.0"
+
+IUSE="+cairo debug doc experimental +glib +graphite icu +introspection test +truetype"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:=[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-util/glib-utils )
+"
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ # bug #726120
+ sed -i \
+ -e '/tests\/macos\.tests/d' \
+ test/shape/data/in-house/Makefile.sources \
+ || die
+
+ # bug #790359
+ filter-flags -fexceptions -fthreadsafe-statics
+
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+
+ # bug #762415
+ local pyscript
+ for pyscript in $(find -type f -name "*.py") ; do
+ python_fix_shebang -q "${pyscript}"
+ done
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for introspection, bug #535852
+ local emesonargs=(
+ -Dcoretext=disabled
+ -Dchafa=disabled
+ -Dwasm=disabled
+
+ $(meson_feature cairo)
+ $(meson_feature glib)
+ $(meson_feature graphite graphite2)
+ $(meson_feature icu)
+ $(meson_feature introspection gobject)
+ $(meson_feature test tests)
+ $(meson_feature truetype freetype)
+
+ $(meson_native_use_feature doc docs)
+ $(meson_native_use_feature introspection)
+ # Breaks building tests..
+ #$(meson_native_use_feature utilities)
+
+ $(meson_use experimental experimental_api)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_test() {
+ # harfbuzz:src / check-static-inits times out on hppa
+ meson_src_test --timeout-multiplier 5
+}