summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gst-plugins-vaapi')
-rw-r--r--media-plugins/gst-plugins-vaapi/Manifest5
-rw-r--r--media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.20.5.ebuild (renamed from media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.5.ebuild)72
-rw-r--r--media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.20.6.ebuild (renamed from media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.16.2.ebuild)74
-rw-r--r--media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.11.ebuild98
-rw-r--r--media-plugins/gst-plugins-vaapi/metadata.xml3
5 files changed, 164 insertions, 88 deletions
diff --git a/media-plugins/gst-plugins-vaapi/Manifest b/media-plugins/gst-plugins-vaapi/Manifest
index 767c8d3f8814..723850fe5aee 100644
--- a/media-plugins/gst-plugins-vaapi/Manifest
+++ b/media-plugins/gst-plugins-vaapi/Manifest
@@ -1,2 +1,3 @@
-DIST gstreamer-vaapi-1.14.5.tar.xz 1068344 BLAKE2B b98363981dc7f111fc8c15188d31dea394b7f6cf300050b95d564b75020931a0f8690d11410f2d3d18d6649ef2ee290c933c3731b4bc3ca43bffb57a4c1bf542 SHA512 287df56ad9bb3fd0754b9f307082eb180c8f0b622e2c9436c5dcf2272a5fb620cb18970726d231688837d52cb169a10e98e14160e51fd82198c34ea612c0d60b
-DIST gstreamer-vaapi-1.16.2.tar.xz 1095012 BLAKE2B 5bf3d34db429d180dfc09cfeccab32f57f7fdad9d05e27ac1aab2ea89e1b14442d4bdb4fd768408b9aee25a117232081adb28447b252c5d553da9d9e0f5b8676 SHA512 61554b5496dca595fa6e278a5634112e225784e9f0a7e731800fd04b395ba4e11dc467b8d074cb8cfed182fa9b9511c104192aecbba3ac755a4c32372061ac9f
+DIST gstreamer-vaapi-1.20.5.tar.xz 801628 BLAKE2B 4c3203baefafccbf8983c9e1da17a3455a0566d27b9a12b4d30292289cded803fb4ae8de1f26ff3536c632984227809df69fa9de78af4190acc30b6750c2d27c SHA512 fd24a58c83b0f820b1b2ca3c179228574a16b9f2657988de0c4569d925f01eb131853b0a322ce95b8523578e66ca66443900af1a5e022ecb4081bfe86a2e23bc
+DIST gstreamer-vaapi-1.20.6.tar.xz 801364 BLAKE2B 891e84099a558b31a152b6be2062753201a3958ce5fb67af37525c7b548404636cfeaa9578cdd485fbaddfabfd929f008ea07d0107975cc8174c58e38e791311 SHA512 3c386400b90ce7a90c0bec2244f0ef1a069cea053915abad3803e67ef7b859276f91a859ba1c959aedbfcb395058a0b0d917e9dd2f148b1cc038469996388af3
+DIST gstreamer-vaapi-1.22.11.tar.xz 552468 BLAKE2B 0353699651add70639a4f7d591eccb646f5d6cda3ba8832553597b7b4e9bd3ebfe07d9eb1ac6e078219ee630131d502adccc8106a2207bb0234353905bafd8cd SHA512 939b748fea88c94ad59c1d4610a872a794b383382096a8f5f011a21d4c8fb041c28e1aa9a8d54f519fb3e48a69ed79622b0d45be01d2d5a900738a7928401563
diff --git a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.5.ebuild b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.20.5.ebuild
index a49b0cece2e8..0bc025df3130 100644
--- a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.5.ebuild
+++ b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.20.5.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+PYTHON_COMPAT=( python3_{8..11} )
-inherit multilib-minimal
+inherit gstreamer-meson python-any-r1
MY_PN="gstreamer-vaapi"
DESCRIPTION="Hardware accelerated video decoding through VA-API plugin for GStreamer"
-HOMEPAGE="https://cgit.freedesktop.org/gstreamer/gstreamer-vaapi"
+HOMEPAGE="https://gitlab.freedesktop.org/gstreamer/gstreamer-vaapi"
SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
LICENSE="LGPL-2.1+"
SLOT="1.0"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
+KEYWORDS="amd64 arm64 ~loong ppc64 ~riscv x86"
IUSE="+drm +egl gles2 +opengl wayland +X" # Keep default enabled IUSE in sync with gst-plugins-base and libva
# gst-vaapi configure is based around GL platform mainly, unlike gst-plugins-bad that goes by GL API mainly; for less surprises,
@@ -44,67 +45,56 @@ REQUIRED_USE="
GST_REQ="${PV}"
GL_DEPS="
>=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[egl?,gles2?,opengl?,wayland?,X?]
- media-libs/mesa[gles2?,egl?,X(+),${MULTILIB_USEDEP}]
+ media-libs/mesa[gles2?,egl(+)?,X?,${MULTILIB_USEDEP}]
"
RDEPEND="
- >=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}]
- >=media-libs/gstreamer-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
>=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
>=media-libs/gst-plugins-bad-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
- >=x11-libs/libva-1.4.0:=[drm?,wayland?,X?,${MULTILIB_USEDEP}]
+ >=media-libs/libva-1.4.0:=[drm(+)?,wayland?,X?,${MULTILIB_USEDEP}]
drm? (
>=virtual/libudev-208:=[${MULTILIB_USEDEP}]
- >=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.98[${MULTILIB_USEDEP}]
)
gles2? ( ${GL_DEPS} )
opengl? ( ${GL_DEPS} )
- wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.11.0[${MULTILIB_USEDEP}] )
X? (
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
>=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
x11-libs/libXrender[${MULTILIB_USEDEP}] )
"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.12
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
S="${WORKDIR}/${MY_PN}-${PV}"
+# FIXME: "Failed to create vaapipostproc element"
+RESTRICT="test"
+
multilib_src_configure() {
- local myconf=()
+ GST_PLUGINS_NOAUTO="wayland"
+
+ local emesonargs=(
+ -Dwith_encoders=yes
+ -Dwith_drm=$(usex drm yes no)
+ -Dwith_x11=$(usex X yes no)
+ -Dwith_wayland=$(usex wayland yes no)
+ )
+
if use opengl || use gles2; then
- myconf+=(
- $(use_enable egl)
- --with-glapi=$(usex opengl 'gl,' '')$(usex gles2 'gles2,gles3' '') # It's fine to have extra commas passed
- )
+ emesonargs+=( -Dwith_egl=$(usex egl yes no) )
else
- myconf+=(
- --disable-egl
- --without-glapi
- )
+ emesonargs+=( -Dwith_egl=no )
fi
if use opengl && use X; then
- myconf+=( --enable-glx )
+ emesonargs+=( -Dwith_glx=yes )
else
- myconf+=( --disable-glx )
+ emesonargs+=( -Dwith_glx=no )
fi
- ECONF_SOURCE=${S} \
- econf \
- --disable-static \
- --disable-debug \
- --disable-examples \
- --enable-encoders \
- $(use_enable drm) \
- $(use_enable X x11) \
- $(use_enable wayland) \
- --without-gtk \
- "${myconf[@]}"
-}
+ # Workaround EGL/eglplatform.h being built with X11 present
+ use X || export CFLAGS="${CFLAGS} -DEGL_NO_X11"
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name '*.la' -delete || die
+ gstreamer_multilib_src_configure
}
diff --git a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.16.2.ebuild b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.20.6.ebuild
index 88adea300f26..0bc025df3130 100644
--- a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.16.2.ebuild
+++ b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.20.6.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+PYTHON_COMPAT=( python3_{8..11} )
-inherit multilib-minimal
+inherit gstreamer-meson python-any-r1
MY_PN="gstreamer-vaapi"
DESCRIPTION="Hardware accelerated video decoding through VA-API plugin for GStreamer"
-HOMEPAGE="https://cgit.freedesktop.org/gstreamer/gstreamer-vaapi"
+HOMEPAGE="https://gitlab.freedesktop.org/gstreamer/gstreamer-vaapi"
SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
LICENSE="LGPL-2.1+"
SLOT="1.0"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
+KEYWORDS="amd64 arm64 ~loong ppc64 ~riscv x86"
IUSE="+drm +egl gles2 +opengl wayland +X" # Keep default enabled IUSE in sync with gst-plugins-base and libva
# gst-vaapi configure is based around GL platform mainly, unlike gst-plugins-bad that goes by GL API mainly; for less surprises,
@@ -44,69 +45,56 @@ REQUIRED_USE="
GST_REQ="${PV}"
GL_DEPS="
>=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[egl?,gles2?,opengl?,wayland?,X?]
- media-libs/mesa[gles2?,egl?,X(+),${MULTILIB_USEDEP}]
+ media-libs/mesa[gles2?,egl(+)?,X?,${MULTILIB_USEDEP}]
"
RDEPEND="
- >=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}]
- >=media-libs/gstreamer-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
>=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
>=media-libs/gst-plugins-bad-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
- >=x11-libs/libva-1.4.0:=[drm?,wayland?,X?,${MULTILIB_USEDEP}]
+ >=media-libs/libva-1.4.0:=[drm(+)?,wayland?,X?,${MULTILIB_USEDEP}]
drm? (
>=virtual/libudev-208:=[${MULTILIB_USEDEP}]
- >=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.98[${MULTILIB_USEDEP}]
)
gles2? ( ${GL_DEPS} )
opengl? ( ${GL_DEPS} )
- wayland? (
- >=dev-libs/wayland-1.11.0[${MULTILIB_USEDEP}]
- >=dev-libs/wayland-protocols-1.15 )
+ wayland? ( >=dev-libs/wayland-1.11.0[${MULTILIB_USEDEP}] )
X? (
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
>=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
x11-libs/libXrender[${MULTILIB_USEDEP}] )
"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.12
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
S="${WORKDIR}/${MY_PN}-${PV}"
+# FIXME: "Failed to create vaapipostproc element"
+RESTRICT="test"
+
multilib_src_configure() {
- local myconf=()
+ GST_PLUGINS_NOAUTO="wayland"
+
+ local emesonargs=(
+ -Dwith_encoders=yes
+ -Dwith_drm=$(usex drm yes no)
+ -Dwith_x11=$(usex X yes no)
+ -Dwith_wayland=$(usex wayland yes no)
+ )
+
if use opengl || use gles2; then
- myconf+=(
- $(use_enable egl)
- --with-glapi=$(usex opengl 'gl,' '')$(usex gles2 'gles2,gles3' '') # It's fine to have extra commas passed
- )
+ emesonargs+=( -Dwith_egl=$(usex egl yes no) )
else
- myconf+=(
- --disable-egl
- --without-glapi
- )
+ emesonargs+=( -Dwith_egl=no )
fi
if use opengl && use X; then
- myconf+=( --enable-glx )
+ emesonargs+=( -Dwith_glx=yes )
else
- myconf+=( --disable-glx )
+ emesonargs+=( -Dwith_glx=no )
fi
- ECONF_SOURCE=${S} \
- econf \
- --disable-static \
- --disable-debug \
- --disable-examples \
- --enable-encoders \
- $(use_enable drm) \
- $(use_enable X x11) \
- $(use_enable wayland) \
- --without-gtk \
- "${myconf[@]}"
-}
+ # Workaround EGL/eglplatform.h being built with X11 present
+ use X || export CFLAGS="${CFLAGS} -DEGL_NO_X11"
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name '*.la' -delete || die
+ gstreamer_multilib_src_configure
}
diff --git a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.11.ebuild b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.11.ebuild
new file mode 100644
index 000000000000..8256a3897829
--- /dev/null
+++ b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.11.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gstreamer-meson
+
+MY_PN="gstreamer-vaapi"
+DESCRIPTION="Hardware accelerated video decoding through VA-API plugin for GStreamer"
+HOMEPAGE="https://gitlab.freedesktop.org/gstreamer/gstreamer-vaapi"
+SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="1.0"
+KEYWORDS="amd64 arm64 ~loong ppc64 ~riscv x86"
+IUSE="+drm +egl +gles2 opengl wayland +X" # Keep default enabled IUSE in sync with gst-plugins-base and libva
+
+# gst-vaapi configure is based around GL platform mainly, unlike gst-plugins-bad that goes by GL API mainly; for less surprises,
+# we design gst-vaapi ebuild in terms of GL API as main choice as well, meaning that USE opengl and/or gles2 is required to
+# enable opengl support at all and choices get chained from there.
+# One or multiple video output are required: drm, x11, glx, egl and/or wayland;
+# but GL API is our main trigger, thus USE=egl should be ineffective if neither gles2 or opengl is enabled;
+# So "|| ( drm egl opengl wayland X )" would be wrong, because egl isn't built with USE="egl -opengl -gles2", ending up with no video outputs.
+# As we ensure at least one working GL output with other REQUIRED_USE, we can put gles2/opengl in REQUIRED_USE instead of egl, solving the issue.
+# gles2 API only supported windowing system (on linux) is EGL, so require it
+# opengl API only supported windowing systems (on linux) are EGL and GLX, so require one of them (glx is enabled with USE="opengl X")
+REQUIRED_USE="
+ || ( drm gles2 opengl wayland X )
+ gles2? ( egl )
+ opengl? ( || ( egl X ) )
+ wayland? ( drm )
+"
+
+# glx doesn't require libva-glx (libva[opengl]) afaics, only by tests/test-display.c
+# USE flag behavior:
+# 'drm' enables vaapi drm support
+# 'egl' enables EGL platform support (but only if also 'opengl||gles2')
+# - 'egl' is exposed as a USE flag mainly to get EGL support instead of or in addition to GLX support with desktop GL while keeping it optional for pure GLX cases;
+# it's always required with USE=gles2, thus USE="gles2 opengl X" will require and build desktop GL EGL platform support as well on top of GLX, which doesn't add extra deps at that point.
+# 'gles2' enables GLESv2 or GLESv3 based GL API support
+# 'opengl' enables desktop OpenGL based GL API support
+# 'wayland' enables non-GL Wayland support; wayland EGL support when combined with 'egl' (but only if also 'opengl||gles2')
+# 'X' enables non-GL X support; GLX support when combined with 'opengl'
+# gst-plugins-bad still needed for codecparsers (GL libraries moved to -base); checked for 1.14 (recheck for 1.16)
+GST_REQ="${PV}"
+GL_DEPS="
+ >=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[egl?,gles2?,opengl?,wayland?,X?]
+ media-libs/mesa[gles2?,egl(+)?,X?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-bad-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/libva-1.10.0:=[drm(+)?,wayland?,X?,${MULTILIB_USEDEP}]
+ drm? (
+ >=virtual/libudev-208:=[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.98[${MULTILIB_USEDEP}]
+ )
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+ wayland? ( >=dev-libs/wayland-1.11.0[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# FIXME: "Failed to create vaapipostproc element"
+RESTRICT="test"
+
+multilib_src_configure() {
+ GST_PLUGINS_NOAUTO="wayland"
+
+ local emesonargs=(
+ -Dencoders=enabled
+ $(meson_feature drm)
+ $(meson_feature X x11)
+ $(meson_feature wayland)
+ )
+
+ if use opengl || use gles2; then
+ emesonargs+=( $(meson_feature egl) )
+ else
+ emesonargs+=( -Degl=disabled )
+ fi
+
+ if use opengl && use X; then
+ emesonargs+=( -Dglx=enabled )
+ else
+ emesonargs+=( -Dglx=disabled )
+ fi
+
+ # Workaround EGL/eglplatform.h being built with X11 present
+ use X || export CFLAGS="${CFLAGS} -DEGL_NO_X11"
+
+ gstreamer_multilib_src_configure
+}
diff --git a/media-plugins/gst-plugins-vaapi/metadata.xml b/media-plugins/gst-plugins-vaapi/metadata.xml
index 73b9785ae4dc..6997730f1472 100644
--- a/media-plugins/gst-plugins-vaapi/metadata.xml
+++ b/media-plugins/gst-plugins-vaapi/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>gstreamer@gentoo.org</email>
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="drm">Enable DRM renderer</flag>
- <flag name="egl">Enable EGL support</flag>
<flag name="gles2">Enable GLESv2 and GLESv3 support</flag>
</use>
</pkgmetadata>