summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch')
-rw-r--r--media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch6
1 files changed, 2 insertions, 4 deletions
diff --git a/media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch b/media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch
index e375969072e3..79f851c9580a 100644
--- a/media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch
+++ b/media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch
@@ -1,5 +1,3 @@
-diff --git a/Makefile b/Makefile
-index 031f865..4d25e97 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@ CC ?= gcc
@@ -7,7 +5,7 @@ index 031f865..4d25e97 100644
# change "-O2 -ffast-math" to "-g -O0" below if you want to debug the plugin
-CPPFLAGS += -Wall -I. -I/usr/include `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gthread-2.0` -D__STDC_FORMAT_MACROS -O2 -ffast-math
-+CPPFLAGS += -Wall -I. -I/usr/include `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gthread-2.0` -D__STDC_FORMAT_MACROS -ffast-math
++CPPFLAGS += -Wall -I. -I/usr/include `pkg-config --cflags gtk+-2.0` `${PKG_CONFIG} --cflags gthread-2.0` -D__STDC_FORMAT_MACROS -ffast-math
LIBS += -lc -lm -lzita-convolver -lsamplerate -lsndfile `pkg-config --libs gthread-2.0` `pkg-config --libs gtk+-2.0`
ifeq ($(shell pkg-config --atleast-version='2.16' gtk+-2.0; echo $$?), 1)
@@ -16,7 +14,7 @@ index 031f865..4d25e97 100644
endif
-C4CFLAGS = -Wall -I. -I/usr/include `pkg-config --cflags gthread-2.0` -O2 -ffast-math
-+C4CFLAGS = -Wall -I. -I/usr/include `pkg-config --cflags gthread-2.0` -ffast-math
++C4CFLAGS = -Wall -I. -I/usr/include `${PKG_CONFIG} --cflags gthread-2.0` -ffast-math
C4LIBS = -lsndfile `pkg-config --libs gthread-2.0`
all: ir.so ir_gui.so