summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/mda-lv2/files/mda-lv2-1.2.10-autoship-disable.patch')
-rw-r--r--media-plugins/mda-lv2/files/mda-lv2-1.2.10-autoship-disable.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/mda-lv2/files/mda-lv2-1.2.10-autoship-disable.patch b/media-plugins/mda-lv2/files/mda-lv2-1.2.10-autoship-disable.patch
new file mode 100644
index 000000000000..c358416ffd85
--- /dev/null
+++ b/media-plugins/mda-lv2/files/mda-lv2-1.2.10-autoship-disable.patch
@@ -0,0 +1,38 @@
+https://gitlab.com/drobilla/mda-lv2/-/commit/e85a6c7fc8e0bccbe23691a6bf10bbbd2ce048bf
+
+From e85a6c7fc8e0bccbe23691a6bf10bbbd2ce048bf Mon Sep 17 00:00:00 2001
+From: David Robillard <d@drobilla.net>
+Date: Mon, 22 Aug 2022 10:50:10 -0400
+Subject: [PATCH] Only run autoship test in strict mode
+
+--- a/meson.build
++++ b/meson.build
+@@ -61,15 +61,17 @@ subdir('mda.lv2')
+ #########
+
+ if not get_option('tests').disabled() and not meson.is_subproject()
+- # Check release metadata
+- autoship = find_program('autoship', required: get_option('tests'))
+- if autoship.found()
+- test(
+- 'autoship',
+- autoship,
+- args: ['test', meson.current_source_dir()],
+- suite: 'data',
+- )
++ if get_option('strict')
++ # Check release metadata
++ autoship = find_program('autoship', required: get_option('tests'))
++ if autoship.found()
++ test(
++ 'autoship',
++ autoship,
++ args: ['test', meson.current_source_dir()],
++ suite: 'data',
++ )
++ endif
+ endif
+
+ # Check licensing metadata
+--
+GitLab