summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/swh-lv2/swh-lv2-1.0.16-r1.ebuild')
-rw-r--r--media-plugins/swh-lv2/swh-lv2-1.0.16-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-plugins/swh-lv2/swh-lv2-1.0.16-r1.ebuild b/media-plugins/swh-lv2/swh-lv2-1.0.16-r1.ebuild
new file mode 100644
index 000000000000..ba17914fd5c8
--- /dev/null
+++ b/media-plugins/swh-lv2/swh-lv2-1.0.16-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Large collection of LV2 audio plugins/effects"
+HOMEPAGE="http://plugin.org.uk/"
+SRC_URI="https://github.com/swh/lv2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lv2-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="sci-libs/fftw:3.0="
+DEPEND="${RDEPEND}"
+BDEPEND="dev-libs/libxslt
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -e 's:-O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops::g' \
+ -i Makefile || die
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake INSTALL_DIR="${D}/usr/$(get_libdir)/lv2" install-system
+ dodoc README
+}