summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-music')
-rw-r--r--media-plugins/vdr-music/Manifest1
-rw-r--r--media-plugins/vdr-music/files/music.mk199
-rw-r--r--media-plugins/vdr-music/metadata.xml14
-rw-r--r--media-plugins/vdr-music/vdr-music-0.9.9.ebuild59
4 files changed, 273 insertions, 0 deletions
diff --git a/media-plugins/vdr-music/Manifest b/media-plugins/vdr-music/Manifest
new file mode 100644
index 000000000000..42bac47b6135
--- /dev/null
+++ b/media-plugins/vdr-music/Manifest
@@ -0,0 +1 @@
+DIST vdr-music-0.9.9-dev2.tgz 2189767 SHA256 90e46c227e08e8539d7c86d7a6b7b5c85eae3374e95bd32f7c62e81ff1e6a017 SHA512 65d9d6b1c76144dfcdb67d884c6cb44066c2bb15ccad0da1e011941b54695f47e4ae104397db1d77d6108ec7cdd81b785901a05fa1c6e07e42df71d021ab1fa7 WHIRLPOOL 45fcab4c44d1b38afd797c53870ead584aa7238d45e0a335d47b41ed31373eaa5af408e5a902cbad6c7e0b942fcd6a80aa316c7684b2bc18052c5c119dc369f4
diff --git a/media-plugins/vdr-music/files/music.mk b/media-plugins/vdr-music/files/music.mk
new file mode 100644
index 000000000000..0b061903df13
--- /dev/null
+++ b/media-plugins/vdr-music/files/music.mk
@@ -0,0 +1,199 @@
+#
+# Makefile for a Video Disk Recorder plugin
+#
+# $Id$
+
+# The official name of this plugin.
+# This name will be used in the '-P...' option of VDR to load the plugin.
+# By default the main source file also carries this name.
+
+PLUGIN = music
+
+### The version number of this plugin (taken from the main source file):
+
+VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+### The directory environment:
+
+# Use package data if installed...otherwise assume we're under the VDR source directory:
+PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
+LIBDIR = $(call PKGCFG,libdir)
+LOCDIR = $(call PKGCFG,locdir)
+PLGCFG = $(call PKGCFG,plgcfg)
+#
+TMPDIR ?= /tmp
+
+### The compiler options:
+
+export CFLAGS = $(call PKGCFG,cflags)
+export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+### The version number of VDR's plugin API:
+
+APIVERSION = $(call PKGCFG,apiversion)
+
+### Allow user defined options to overwrite defaults:
+
+-include $(PLGCFG)
+
+### The name of the distribution archive:
+
+ARCHIVE = $(PLUGIN)-$(VERSION)
+PACKAGE = vdr-$(ARCHIVE)
+
+### The name of the shared object file:
+
+SOFILE = libvdr-$(PLUGIN).so
+
+### Includes and Defines (add further entries here):
+
+# (Default) DO NOT UNCOMMENT IT IN DEVELOPER-VERSIONS
+HAVE_IMAGEMAGICK=1
+# Uncomment the following line, if you don't have libsndfile installed
+#WITHOUT_LIBSNDFILE=1
+
+# Uncomment the following line, if you don't have libvorbisfile installed
+#WITHOUT_LIBVORBISFILE=1
+
+#BROKEN_PCM=1
+# Uncomment if you want debug output on stdout
+##DEBUG=1
+
+# internal use
+# BUGHUNT
+#BUGHUNT=1
+
+# internal use
+# DEBUG_COVER
+#DEBUG_COVER=1
+
+###INCLUDES +=
+
+###DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+INCLUDES += -I$(VDRINCDIR)
+
+DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+ifdef BROKEN_PCM
+ DEFINES += -DBROKEN_PCM
+endif
+
+ifeq ($(shell test -f $(VDRDIR)/fontsym.h ; echo $$?),0)
+ DEFINES += -DHAVE_BEAUTYPATCH
+endif
+
+ifdef DBG
+ CXXFLAGS += -g
+endif
+
+ifdef DEBUG
+ DEFINES += -DDEBUG
+else
+ DEFINES += -DNO_DEBUG
+endif
+
+ifdef BUGHUNT
+ DEFINES += -DBUGHUNT
+endif
+
+ifdef DEBUG_COVER
+ DEFINES += -DDEBUG_COVER
+endif
+
+### The object files (add further files here):
+
+OBJS = $(PLUGIN).o config.o vars.o bitmap.o \
+ commands.o options.o lyrics.o funct.o cover.o skin.o visual.o tracklist.o \
+ search.o mp3id3.o mp3id3tag.o rating.o menubrowse.o mp3control.o \
+ icons.o data.o menu.o \
+ data-mp3.o setup-mp3.o player-mp3.o stream.o network.o \
+ decoder.o decoder-mp3.o decoder-mp3-stream.o decoder-snd.o \
+ decoder-ogg.o
+
+LIBS += -lasound -lmad -lid3tag
+
+ifdef HAVE_IMAGEMAGICK
+ INCLUDES += $(shell pkg-config --cflags MagickCore)
+ LIBS += $(shell pkg-config --libs Magick++)
+ DEFINES += -DHAVE_IMAGEMAGICK
+else
+ INCLUDES += -I$(IMLIB)/src
+ LIBS += $(shell imlib2-config --libs)
+ DEFINES += -DHAVE_IMLIB2
+endif
+
+ifndef WITHOUT_LIBSNDFILE
+ LIBS += -lsndfile
+ DEFINES += -DHAVE_SNDFILE
+endif
+
+ifndef WITHOUT_LIBVORBISFILE
+ LIBS += -lvorbisfile -lvorbis
+ DEFINES += -DHAVE_VORBISFILE
+endif
+
+### The main target:
+
+all: $(SOFILE) i18n
+
+### Implicit rules:
+
+%.o: %.c
+ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+### Dependencies:
+
+MAKEDEP = $(CXX) -MM -MG
+DEPFILE = .dependencies
+$(DEPFILE): Makefile
+ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+-include $(DEPFILE)
+
+### Internationalization (I18N):
+
+PODIR = po
+I18Npo = $(wildcard $(PODIR)/*.po)
+I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
+I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+I18Npot = $(PODIR)/$(PLUGIN).pot
+
+%.mo: %.po
+ msgfmt -c -o $@ $<
+
+$(I18Npot): $(wildcard *.c)
+ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
+
+%.po: $(I18Npot)
+ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
+ @touch $@
+
+$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ install -D -m644 $< $@
+
+.PHONY: i18n
+i18n: $(I18Nmo) $(I18Npot)
+
+install-i18n: $(I18Nmsgs)
+
+### Targets:
+
+$(SOFILE): $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
+
+install-lib: $(SOFILE)
+ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
+
+install: install-lib install-i18n
+
+dist: $(I18Npo) clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+ @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @echo Distribution package created as $(PACKAGE).tgz
+
+clean:
+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-music/metadata.xml b/media-plugins/vdr-music/metadata.xml
new file mode 100644
index 000000000000..8360ea6f19cf
--- /dev/null
+++ b/media-plugins/vdr-music/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<use>
+ <flag name='graphtft'>Enable support for
+ <pkg>media-plugins/vdr-graphtft</pkg></flag>
+</use>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-music/vdr-music-0.9.9.ebuild b/media-plugins/vdr-music/vdr-music-0.9.9.ebuild
new file mode 100644
index 000000000000..964ab2519252
--- /dev/null
+++ b/media-plugins/vdr-music/vdr-music-0.9.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+MY_P="${P}-dev2"
+S="${WORKDIR}/music-${PV}-dev2"
+
+DESCRIPTION="VDR plugin: music"
+HOMEPAGE="http://www.vdr.glaserei-franz.de/vdrplugins.htm"
+SRC_URI="http://www.glaserei-franz.de/VDR/Moronimo/files/${MY_P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+imagemagick debug graphtft sndfile vorbis"
+
+DEPEND=">=media-video/vdr-1.6.0
+ media-libs/libmad
+ media-libs/libid3tag
+ graphtft? ( media-gfx/imagemagick[png] )
+ imagemagick? ( media-gfx/imagemagick[png] )
+ sndfile? ( media-libs/libsndfile )
+ vorbis? ( media-libs/libvorbis )
+ !imagemagick? (
+ !graphtft? ( media-libs/imlib2[png] )
+ )"
+
+RDEPEND="sys-process/at
+ media-sound/id3v2
+ graphtft? ( >=media-plugins/vdr-graphtft-0.1.5 )"
+
+src_prepare() {
+# # prepare sources with new Makefile handling
+# cp "${FILESDIR}/music.mk" "${S}"/Makefile
+
+ # clean up from untranslated .po files
+ rm "${S}"/po/{ca_ES,cs_CZ,da_DK,el_GR,es_ES,et_EE,fi_FI,fr_FR,hr_HR,hu_HU,it_IT,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+ vdr-plugin-2_src_prepare
+
+ use !vorbis && sed -i Makefile -e "s:#WITHOUT_LIBVORBISFILE=1:WITHOUT_LIBVORBISFILE=1:"
+ use !sndfile && sed -i Makefile -e "s:#WITHOUT_LIBSNDFILE=1:WITHOUT_LIBSNDFILE=1:"
+ use !debug && sed -i Makefile -e "s:DEBUG=1:#DEBUG=1:"
+ use graphtft || use imagemagick && sed -i Makefile \
+ -e "s:#HAVE_MAGICK=1:HAVE_MAGICK=1:" \
+ -e "s:#MAGICKDIR=:MAGICKDIR=:"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/plugins/music
+ doins -r moronsuite/music/*
+ chown -R vdr:vdr "${D}"/etc/vdr/plugins/music
+}