summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/zam-plugins/zam-plugins-3.14.ebuild')
-rw-r--r--media-plugins/zam-plugins/zam-plugins-3.14.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/media-plugins/zam-plugins/zam-plugins-3.14.ebuild b/media-plugins/zam-plugins/zam-plugins-3.14.ebuild
index 90423a2f5c28..f3d77dcc5a73 100644
--- a/media-plugins/zam-plugins/zam-plugins-3.14.ebuild
+++ b/media-plugins/zam-plugins/zam-plugins-3.14.ebuild
@@ -46,7 +46,10 @@ src_compile() {
emake PREFIX=/usr LIBDIR=$(get_libdir) VERBOSE=true \
BASE_OPTS="" SKIP_STRIPPING=true \
HAVE_ZITA_CONVOLVER=true \
+ HAVE_CAIRO=$(usex opengl true false) \
HAVE_DGL=$(usex opengl true false) \
+ HAVE_OPENGL=$(usex opengl true false) \
+ UI_TYPE=$(usex opengl "opengl" "none") \
HAVE_JACK=$(usex jack true false)
}
@@ -54,7 +57,10 @@ src_install() {
emake PREFIX=/usr LIBDIR=$(get_libdir) VERBOSE=true \
BASE_OPTS="" SKIP_STRIPPING=true \
HAVE_ZITA_CONVOLVER=true \
+ HAVE_CAIRO=$(usex opengl true false) \
HAVE_DGL=$(usex opengl true false) \
+ HAVE_OPENGL=$(usex opengl true false) \
+ UI_TYPE=$(usex opengl "opengl" "none") \
HAVE_JACK=$(usex jack true false) \
DESTDIR="${ED}" install
}