summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/cqrlog/cqrlog-2.4.0.ebuild')
-rw-r--r--media-radio/cqrlog/cqrlog-2.4.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-radio/cqrlog/cqrlog-2.4.0.ebuild b/media-radio/cqrlog/cqrlog-2.4.0.ebuild
new file mode 100644
index 000000000000..a470fe94b73d
--- /dev/null
+++ b/media-radio/cqrlog/cqrlog-2.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="CQRLOG is an advanced ham radio logger based on MySQL database"
+HOMEPAGE="https://www.cqrlog.com/ https://github.com/ok2cqr/cqrlog"
+SRC_URI="https://github.com/ok2cqr/cqrlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/lazarus-1.8.0
+ >=dev-lang/fpc-3.0.2"
+
+RDEPEND="${DEPEND}
+ virtual/mysql[server]
+ dev-libs/atk
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+
+ x11-libs/libX11
+ x11-libs/pango"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
+pkg_postist() {
+ optfeature "monitoring radio settings" media-libs/hamlib
+}