summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/gpredict/gpredict-1.3-r2.ebuild')
-rw-r--r--media-radio/gpredict/gpredict-1.3-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-radio/gpredict/gpredict-1.3-r2.ebuild b/media-radio/gpredict/gpredict-1.3-r2.ebuild
new file mode 100644
index 000000000000..4d41ca55836b
--- /dev/null
+++ b/media-radio/gpredict/gpredict-1.3-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Real-time satellite tracking and orbit prediction application"
+HOMEPAGE="http://gpredict.oz9aec.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/gtk+:2
+ x11-libs/goocanvas:0
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ # remove wrong doc location
+ epatch "${FILESDIR}/${PN}-1.3-doc.patch"
+ sed -i -e "s/0.15/0.14/g" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ make_desktop_entry ${PN} "GPredict" "/usr/share/pixmaps/gpredict/icons/gpredict-icon.png" Science
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}