summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/tucnak2')
-rw-r--r--media-radio/tucnak2/Manifest1
-rw-r--r--media-radio/tucnak2/files/tucnak2-2.42-appname.diff23
-rw-r--r--media-radio/tucnak2/files/tucnak2-2.48-doc.diff19
-rw-r--r--media-radio/tucnak2/files/tucnak2-2.48-hamlib.diff35
-rw-r--r--media-radio/tucnak2/metadata.xml13
-rw-r--r--media-radio/tucnak2/tucnak2-2.48.ebuild68
6 files changed, 159 insertions, 0 deletions
diff --git a/media-radio/tucnak2/Manifest b/media-radio/tucnak2/Manifest
new file mode 100644
index 000000000000..cd13936f0406
--- /dev/null
+++ b/media-radio/tucnak2/Manifest
@@ -0,0 +1 @@
+DIST tucnak2-2.48.tar.gz 2985018 SHA256 6399ea57d782dafdc68188490ad003b256fe7ed2b02385d1b3882fd9df294c97 SHA512 e2803fb492ff7bab0fd698587de1a92805be8d7cb3935ac8ad7119ada8981399add8bf30842ba1155aaad6a5cd9b48300c16d2c38e66516188fb2e81f8f08f20 WHIRLPOOL 3a763f768477ae0068ce71d13a151cf566b77ec122f0d8b7b9df82cbde659aaf37ed676ea7c35f26e263974d6d8dc5dd645ccc3dca92934c97b2b80fab896fe0
diff --git a/media-radio/tucnak2/files/tucnak2-2.42-appname.diff b/media-radio/tucnak2/files/tucnak2-2.42-appname.diff
new file mode 100644
index 000000000000..3d832ef78ab8
--- /dev/null
+++ b/media-radio/tucnak2/files/tucnak2-2.42-appname.diff
@@ -0,0 +1,23 @@
+
+--- src/Makefile.am.orig 2011-05-12 17:51:43.000000000 +0200
++++ src/Makefile.am 2011-05-12 17:52:01.000000000 +0200
+@@ -1,9 +1,9 @@
+ datarootdir = @datarootdir@
+
+ #bin_PROGRAMS = tucnak soundwrapper stucnak
+-bin_PROGRAMS = tucnak soundwrapper
++bin_PROGRAMS = tucnak2 soundwrapper
+
+-tucnak_SOURCES = adif.c alsa.c bfu.c cabrillo.c charsets.c \
++tucnak2_SOURCES = adif.c alsa.c bfu.c cabrillo.c charsets.c \
+ chart.c codepage.h codepage.inc \
+ control.c cor.c cor.h cordata.c cordata.h cordata.inc \
+ cwdaemon.c cwdb.c cwwindow.c davac4.c dsp.c dwdb.c dxc.c ebw.c edi.c \
+@@ -24,7 +24,7 @@
+ ttys.c txts.c txts.h txts.inc uni_7b.inc \
+ win32.c winkey.c wiki.c wizz.c zstring.c
+
+-tucnak_LDADD = @TUCNAK_LDADD@
++tucnak2_LDADD = @TUCNAK_LDADD@
+
+ soundwrapper_SOURCES = soundwrapper.c
diff --git a/media-radio/tucnak2/files/tucnak2-2.48-doc.diff b/media-radio/tucnak2/files/tucnak2-2.48-doc.diff
new file mode 100644
index 000000000000..efac0b22d189
--- /dev/null
+++ b/media-radio/tucnak2/files/tucnak2-2.48-doc.diff
@@ -0,0 +1,19 @@
+--- Makefile.am.orig 2011-02-25 18:29:32.000000000 +0100
++++ Makefile.am 2011-02-25 18:29:52.000000000 +0100
+@@ -1,15 +1,11 @@
+ datarootdir = @datarootdir@
+
+-SUBDIRS=data debian.unofficial doc intl pkg share src win32
++SUBDIRS=data intl pkg share src win32
+
+ MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in stamp-h.in
+
+ EXTRA_DIST = COPYING INSTALL leaks rebuild eee.sh
+
+-docsdir = $(datadir)/tucnak2/doc
+-
+-docs_DATA = AUTHORS ChangeLog TODO
+-
+ stamp = `date +%Y%m%d_%H%M%S`
+
+ distd: dist
diff --git a/media-radio/tucnak2/files/tucnak2-2.48-hamlib.diff b/media-radio/tucnak2/files/tucnak2-2.48-hamlib.diff
new file mode 100644
index 000000000000..f0d573837a77
--- /dev/null
+++ b/media-radio/tucnak2/files/tucnak2-2.48-hamlib.diff
@@ -0,0 +1,35 @@
+# Fix forgotten #ifdef if hamlib not available
+--- src/rotar.c.orig 2012-03-13 14:35:34.000000000 +0100
++++ src/rotar.c 2012-06-04 17:26:54.000000000 +0200
+@@ -20,12 +20,13 @@
+
+ gpointer rot_hamlib_main(gpointer xxx);
+
++#ifdef HAVE_HAMLIB
+ static int rot_print_model_list(const struct rot_caps *caps, void *data)
+ {
+ log_addf("%-6d %-14s %-20s %s\n", caps->rot_model, caps->mfg_name, caps->model_name, caps->version);
+ return 1; /* !=0, we want them all ! */
+ }
+-
++#endif
+
+ struct rotar *init_rotar(struct config_rotar *crot, int rotchar){
+ struct rotar *rot;
+@@ -117,13 +118,15 @@
+ }
+
+ void free_rotar(struct rotar *rot){
+- if (rot->hl_thread){
++#ifdef HAVE_HAMLIB
++ if (rot->hl_thread){
+ rot->hl_thread_break = 1;
+ dbg("join hamlib rotar...\n");
+ g_thread_join(rot->hl_thread);
+ dbg("done\n");
+ rot->hl_thread=0;
+ }
++#endif
+ g_free(rot->desc);
+ g_free(rot->netid);
+ g_free(rot->rem_rotstr);
diff --git a/media-radio/tucnak2/metadata.xml b/media-radio/tucnak2/metadata.xml
new file mode 100644
index 000000000000..762649e56d69
--- /dev/null
+++ b/media-radio/tucnak2/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+ <use>
+ <flag name='ftdi'>Enable support for FTDI USB chips</flag>
+ <flag name='hamlib'>Enables support by the Hamlib amateur radio
+ rig control library to get/set frequency and mode of the ham radio</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-radio/tucnak2/tucnak2-2.48.ebuild b/media-radio/tucnak2/tucnak2-2.48.ebuild
new file mode 100644
index 000000000000..6735d795b003
--- /dev/null
+++ b/media-radio/tucnak2/tucnak2-2.48.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils autotools
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="alsa fftw ftdi gpm hamlib suid"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/libsndfile
+ >=media-libs/libsdl-1.2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0 )
+ ftdi? ( dev-embedded/libftdi )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib )
+ >=media-libs/libpng-1.2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # fix destop file bug 483730
+ sed -i -e "s/HamRadio/HamRadio;/" share/applications/tucnak2.desktop || die
+ epatch "${FILESDIR}/${P}-doc.diff" \
+ "${FILESDIR}/${PN}-2.42-appname.diff" \
+ "${FILESDIR}/${P}-hamlib.diff"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with alsa) $(use_with ftdi) \
+ $(use_with gpm) $(use_with hamlib) \
+ $(use_with fftw fftw3) --with-sdl
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman debian.unofficial/tucnak2.1
+ dodoc AUTHORS ChangeLog TODO doc/NAVOD.pdf
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak2 add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak2 can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}