summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/wsjtx')
-rw-r--r--media-radio/wsjtx/files/wsjtx-clang.patch20
-rw-r--r--media-radio/wsjtx/wsjtx-2.2.2.ebuild3
2 files changed, 22 insertions, 1 deletions
diff --git a/media-radio/wsjtx/files/wsjtx-clang.patch b/media-radio/wsjtx/files/wsjtx-clang.patch
new file mode 100644
index 000000000000..bb6c97a538f6
--- /dev/null
+++ b/media-radio/wsjtx/files/wsjtx-clang.patch
@@ -0,0 +1,20 @@
+--- a/CMakeLists.txt 2020-09-08 10:36:55.770304108 +0200
++++ b/CMakeLists.txt 2020-09-08 10:37:28.346406308 +0200
+@@ -1193,7 +1193,7 @@
+ if (OpenMP_C_FLAGS)
+ set_target_properties (wsjt_fort_omp
+ PROPERTIES
+- COMPILE_FLAGS "${OpenMP_C_FLAGS}"
++ COMPILE_FLAGS "${OpenMP_Fortran_FLAGS}"
+ )
+ endif ()
+ set_target_properties (wsjt_fort_omp
+@@ -1260,7 +1260,7 @@
+ if (OpenMP_C_FLAGS)
+ set_target_properties (jt9
+ PROPERTIES
+- COMPILE_FLAGS "${OpenMP_C_FLAGS}"
++ COMPILE_FLAGS "${OpenMP_Fortran_FLAGS}"
+ LINK_FLAGS "${OpenMP_C_FLAGS}"
+ )
+ endif ()
diff --git a/media-radio/wsjtx/wsjtx-2.2.2.ebuild b/media-radio/wsjtx/wsjtx-2.2.2.ebuild
index 01c2452f0a84..923305c594b1 100644
--- a/media-radio/wsjtx/wsjtx-2.2.2.ebuild
+++ b/media-radio/wsjtx/wsjtx-2.2.2.ebuild
@@ -41,7 +41,8 @@ PATCHES=( "${FILESDIR}/${PN}-2.0.1-hamlib.patch"
"${FILESDIR}/${PN}-fix-unicode.patch"
"${FILESDIR}/${PN}-drop-docs.patch"
"${FILESDIR}/${PN}-2.1.2-qt_helpers.patch"
- "${FILESDIR}/${PN}-2.2.0-werror.patch" )
+ "${FILESDIR}/${PN}-2.2.0-werror.patch"
+ "${FILESDIR}/${PN}-clang.patch" )
DOCS=( AUTHORS BUGS NEWS README THANKS )