summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/amsynth')
-rw-r--r--media-sound/amsynth/Manifest1
-rw-r--r--media-sound/amsynth/amsynth-1.13.4.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/amsynth/Manifest b/media-sound/amsynth/Manifest
index 9cea6030c8dd..a25f33ed839f 100644
--- a/media-sound/amsynth/Manifest
+++ b/media-sound/amsynth/Manifest
@@ -1,2 +1,3 @@
DIST amsynth-1.13.2.tar.gz 1621330 BLAKE2B 04f0b81e0a63f4f0bbd6b1dbc92c9ae638a46ad5e5b0bbaaf99cd7cf53761e3a599e6c15f303ea509e53e5aaf8d9040e17e783c8111abdf4fa4837dcd50092d1 SHA512 b93949d3be3c484a27534bd515b12a460aa07d353635b09ecee0e731bf27025b4bf4684e2968cf3a7887c765e1ad80a912fd86582c6f028738fa60df82a40f86
DIST amsynth-1.13.3.tar.gz 1641606 BLAKE2B 65c1bffa46f71f1fe9c89288da700348670575c59738f43f6b712ddb6555770677926fbac508dc11f7e34829bcb46f66cc850a651a2bcbeab3b63555aa4f2abd SHA512 b7d1592d6d4b06fa1d6b3892804433bde617d566044aad82c93d0e75af30ea04d07c3ed98cc9ff24c83efd4b829d109ecc4e7758d0a13127f7e6642ebb74c119
+DIST amsynth-1.13.4.tar.gz 1641690 BLAKE2B 7041009e34f3b7b82db89d64e515fd542c1be06328317fdbabca6c3a8aea158e71d9372c83e65235b84cdd6c409d7f83830203418cdb49b195124a64668aceb7 SHA512 94da080036667cc89dd22c04cadc8993fa4ff534b0f009f84d374fa20d391928a3b104287e6c6856edbdb1e5d26daf2c730a73fc08734db8c7eb62c8f35cc129
diff --git a/media-sound/amsynth/amsynth-1.13.4.ebuild b/media-sound/amsynth/amsynth-1.13.4.ebuild
new file mode 100644
index 000000000000..f736fc0d0a4c
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.13.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/amsynth/amsynth"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa dssi gtk jack lash lv2 nsm oss vst"
+
+REQUIRED_USE="dssi? ( gtk ) lv2? ( gtk ) vst? ( gtk )"
+
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+RDEPEND="
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ )
+ gtk? (
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )
+ lv2? ( media-libs/lv2 )
+"
+DEPEND="${RDEPEND}
+ oss? ( virtual/os-headers )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.12.2-metadata.patch"
+)
+
+src_prepare() {
+ default
+ ! use gtk && eapply "${FILESDIR}/${PN}-1.12.2-x11.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_with alsa) \
+ $(use_with dssi) \
+ $(use_with gtk gui) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with lv2) \
+ $(use_with nsm) \
+ $(use_with oss) \
+ $(use_with vst)
+}