summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/audacity/files')
-rw-r--r--media-sound/audacity/files/audacity-2.4.2-fix-gettimeofday.patch12
-rw-r--r--media-sound/audacity/files/audacity-2.4.2-fix-metainfo.patch12
-rw-r--r--media-sound/audacity/files/audacity-2.4.2-fix-vertical-track-resizing.patch14
3 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/audacity/files/audacity-2.4.2-fix-gettimeofday.patch b/media-sound/audacity/files/audacity-2.4.2-fix-gettimeofday.patch
new file mode 100644
index 000000000000..0e6e3e5d8cb1
--- /dev/null
+++ b/media-sound/audacity/files/audacity-2.4.2-fix-gettimeofday.patch
@@ -0,0 +1,12 @@
+diff --git a/src/AudioIO.cpp b/src/AudioIO.cpp
+index 0187e39..28a5348 100644
+--- a/src/AudioIO.cpp
++++ b/src/AudioIO.cpp
+@@ -427,6 +427,7 @@ time warp info and AudioIOListener and whether the playback is looped.
+ #include <math.h>
+ #include <stdlib.h>
+ #include <algorithm>
++#include <sys/time.h>
+
+ #ifdef __WXMSW__
+ #include <malloc.h>
diff --git a/media-sound/audacity/files/audacity-2.4.2-fix-metainfo.patch b/media-sound/audacity/files/audacity-2.4.2-fix-metainfo.patch
new file mode 100644
index 000000000000..09b9fd0e868b
--- /dev/null
+++ b/media-sound/audacity/files/audacity-2.4.2-fix-metainfo.patch
@@ -0,0 +1,12 @@
+diff --git a/help/CMakeLists.txt b/help/CMakeLists.txt
+index 43a7714..0e8a3d8 100755
+--- a/help/CMakeLists.txt
++++ b/help/CMakeLists.txt
+@@ -40,6 +40,6 @@ if( NOT "${CMAKE_GENERATOR}" MATCHES "Xcode|Visual Studio*" )
+ install( FILES "${_SRCDIR}/audacity.1"
+ DESTINATION "${_MANDIR}/man1" )
+ install( FILES "${_SRCDIR}/audacity.appdata.xml"
+- DESTINATION "${_DATADIR}/appdata" )
++ DESTINATION "${_DATADIR}/metainfo" )
+ endif()
+
diff --git a/media-sound/audacity/files/audacity-2.4.2-fix-vertical-track-resizing.patch b/media-sound/audacity/files/audacity-2.4.2-fix-vertical-track-resizing.patch
new file mode 100644
index 000000000000..71160b4365eb
--- /dev/null
+++ b/media-sound/audacity/files/audacity-2.4.2-fix-vertical-track-resizing.patch
@@ -0,0 +1,14 @@
+--- a/src/menus/ViewMenus.cpp 2020-05-27 17:49:20.645538517 +0500
++++ b/src/menus/ViewMenus.cpp 2020-05-27 17:49:26.844538493 +0500
+@@ -4,10 +4,10 @@
+ #include "../CommonCommandFlags.h"
+ #include "../Menus.h"
+ #include "../Prefs.h"
++#include "../ProjectWindow.h"
+ #include "../Project.h"
+ #include "../ProjectHistory.h"
+ #include "../ProjectSettings.h"
+-#include "../ProjectWindow.h"
+ #include "../Track.h"
+ #include "../TrackInfo.h"
+ #include "../TrackPanel.h"