summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/clementine/files')
-rw-r--r--media-sound/clementine/files/clementine-1.3-fix-tokenizer.patch4
-rw-r--r--media-sound/clementine/files/clementine-1.3_rc1-cmake.patch32
2 files changed, 34 insertions, 2 deletions
diff --git a/media-sound/clementine/files/clementine-1.3-fix-tokenizer.patch b/media-sound/clementine/files/clementine-1.3-fix-tokenizer.patch
index 6413bf77de3f..437518695a32 100644
--- a/media-sound/clementine/files/clementine-1.3-fix-tokenizer.patch
+++ b/media-sound/clementine/files/clementine-1.3-fix-tokenizer.patch
@@ -1,7 +1,7 @@
https://github.com/clementine-player/Clementine/issues/5297
---- src/core/database.cpp
-+++ src/core/database.cpp
+--- a/src/core/database.cpp
++++ b/src/core/database.cpp
@@ -265,6 +265,16 @@
StaticInit();
diff --git a/media-sound/clementine/files/clementine-1.3_rc1-cmake.patch b/media-sound/clementine/files/clementine-1.3_rc1-cmake.patch
new file mode 100644
index 000000000000..22a922b86136
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.3_rc1-cmake.patch
@@ -0,0 +1,32 @@
+--- Clementine-1.3rc1/CMakeLists.txt
++++ Clementine-1.3rc1/CMakeLists.txt
+@@ -60,7 +60,7 @@
+
+ pkg_check_modules(CDIO libcdio)
+ pkg_check_modules(CHROMAPRINT REQUIRED libchromaprint)
+-pkg_search_module(CRYPTOPP cryptopp libcrypto++)
++#pkg_search_module(CRYPTOPP cryptopp libcrypto++)
+ pkg_check_modules(GIO gio-2.0)
+ pkg_check_modules(GLIB REQUIRED glib-2.0)
+ pkg_check_modules(GOBJECT REQUIRED gobject-2.0)
+@@ -275,13 +275,14 @@
+
+ optional_component(VISUALISATIONS ON "Visualisations")
+
+-if(NOT HAVE_SPOTIFY_BLOB AND NOT CRYPTOPP_FOUND)
+- message(FATAL_ERROR "Either crypto++ must be available or the non-GPL Spotify "
+- "code must be compiled in")
+-elseif(CRYPTOPP_FOUND)
++#if(NOT HAVE_SPOTIFY_BLOB AND NOT CRYPTOPP_FOUND)
++# message(FATAL_ERROR "Either crypto++ must be available or the non-GPL Spotify "
++# "code must be compiled in")
++#elseif(CRYPTOPP_FOUND)
+ set(HAVE_CRYPTOPP ON)
+- set(HAVE_SPOTIFY_DOWNLOADER ON)
+-endif()
++ set(HAVE_SPOTIFY_DOWNLOADER OFF)
++ set(HAVE_SPOTIFY_BLOB OFF)
++#endif()
+
+ # Find DBus if it's enabled
+ if (HAVE_DBUS)