summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/codecgraph/codecgraph-20120114-r2.ebuild')
-rw-r--r--media-sound/codecgraph/codecgraph-20120114-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/codecgraph/codecgraph-20120114-r2.ebuild b/media-sound/codecgraph/codecgraph-20120114-r2.ebuild
new file mode 100644
index 000000000000..799e395e9eb5
--- /dev/null
+++ b/media-sound/codecgraph/codecgraph-20120114-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Generates a graph based on the ALSA description of an HD Audio codec"
+HOMEPAGE="http://helllabs.org/codecgraph/"
+SRC_URI="http://helllabs.org/codecgraph/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ media-gfx/imagemagick"
+
+PATCHES=( "${FILESDIR}/${PV}-makefile-prefix.diff" )
+
+src_configure() {
+ python_fix_shebang *.py
+}
+
+src_install() {
+ default
+ dodoc codecs.txt IDEAS
+}