summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/darkice/darkice-1.3.ebuild')
-rw-r--r--media-sound/darkice/darkice-1.3.ebuild31
1 files changed, 14 insertions, 17 deletions
diff --git a/media-sound/darkice/darkice-1.3.ebuild b/media-sound/darkice/darkice-1.3.ebuild
index b3c01b466369..5ea84fbe503f 100644
--- a/media-sound/darkice/darkice-1.3.ebuild
+++ b/media-sound/darkice/darkice-1.3.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils
DESCRIPTION="A live audio streamer"
HOMEPAGE="http://www.darkice.org/"
@@ -28,23 +27,21 @@ DEPEND="${RDEPEND}"
REQUIRED_USE="|| ( aac aacplus mp3 opus twolame vorbis )
|| ( alsa jack pulseaudio )"
-#PATCHES=(
-# "${FILESDIR}"/${PN}-1.2-gcc47.patch
-#)
-
src_configure() {
- econf \
- $(use_enable debug) \
- $(use_with aac faac) \
- $(use_with aacplus) \
- $(use_with alsa) \
- $(use_with jack) \
- $(use_with libsamplerate samplerate) \
- $(use_with mp3 lame) \
- $(use_with opus) \
- $(use_with pulseaudio) \
- $(use_with twolame) \
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_with aac faac)
+ $(use_with aacplus)
+ $(use_with alsa)
+ $(use_with jack)
+ $(use_with libsamplerate samplerate)
+ $(use_with mp3 lame)
+ $(use_with opus)
+ $(use_with pulseaudio)
+ $(use_with twolame)
$(use_with vorbis)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {