summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gnome-sound-recorder/gnome-sound-recorder-3.24.0.1.ebuild')
-rw-r--r--media-sound/gnome-sound-recorder/gnome-sound-recorder-3.24.0.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/gnome-sound-recorder/gnome-sound-recorder-3.24.0.1.ebuild b/media-sound/gnome-sound-recorder/gnome-sound-recorder-3.24.0.1.ebuild
new file mode 100644
index 000000000000..461f3c7fefe3
--- /dev/null
+++ b/media-sound/gnome-sound-recorder/gnome-sound-recorder-3.24.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Simple sound recorder"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/SoundRecorder"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-libs/gjs
+ >=dev-libs/glib-2.46:2
+ >=dev-libs/gobject-introspection-1.31.6
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.12:3[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection,ogg]
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-flac:1.0
+ media-plugins/gst-plugins-pulse:1.0
+
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.26
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: upstream should provide a way to set GST_INSPECT, bug #358755 & co.
+ # gst-inspect causes sandbox violations when a plugin needs write access to
+ # /dev/dri/card* in its init phase.
+ sed -e "s|\(gst10_inspect=\).*|\1$(type -P true)|" \
+ -i configure || die
+}