summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gtklick/gtklick-0.6.4.ebuild')
-rw-r--r--media-sound/gtklick/gtklick-0.6.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/gtklick/gtklick-0.6.4.ebuild b/media-sound/gtklick/gtklick-0.6.4.ebuild
new file mode 100644
index 000000000000..948729649944
--- /dev/null
+++ b/media-sound/gtklick/gtklick-0.6.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="A simple metronome with an easy-to-use GTK interface"
+HOMEPAGE="http://das.nasophon.de/gtklick/"
+SRC_URI="http://das.nasophon.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="dev-python/pygtk[${PYTHON_USEDEP}]
+ media-libs/pyliblo[${PYTHON_USEDEP}]
+ media-sound/klick[osc]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+
+ # Replace the broken default runner script with a working one.
+ sed \
+ -e "s|[@]sharedir[@]|${EPREFIX}/usr/share/${PN}|g" \
+ -e "s|[@]localedir[@]|${EPREFIX}/usr/share/locale|g" \
+ "${FILESDIR}"/${PN} > "${T}"/${PN}
+ python_replicate_script "${T}"/${PN}
+}