summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/liblc3/liblc3-1.0.4.ebuild')
-rw-r--r--media-sound/liblc3/liblc3-1.0.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-sound/liblc3/liblc3-1.0.4.ebuild b/media-sound/liblc3/liblc3-1.0.4.ebuild
new file mode 100644
index 000000000000..3a165a2cd464
--- /dev/null
+++ b/media-sound/liblc3/liblc3-1.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="LC3 is an efficient low latency audio codec"
+HOMEPAGE="https://github.com/google/liblc3"
+SRC_URI="https://github.com/google/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="tools"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+src_configure() {
+ local emesonargs=(
+ # We let users choose to enable LTO
+ -Db_lto=false
+ $(meson_use tools)
+ )
+ meson_src_configure
+}