summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/lilypond/lilypond-9999.ebuild')
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index 50b935febd44..4a04aea78500 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
PYTHON_COMPAT=( python3_{9..11} )
inherit elisp-common autotools python-single-r1 toolchain-funcs xdg-utils
-if [[ "${PV}" = "9999" ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.savannah.gnu.org/git/lilypond.git"
else
MAIN_VER=$(ver_cut 1-2)
- SRC_URI="http://lilypond.org/download/sources/v${MAIN_VER}/${P}.tar.gz"
+ SRC_URI="https://lilypond.org/download/sources/v${MAIN_VER}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~riscv ~x86"
fi
@@ -21,7 +22,7 @@ HOMEPAGE="http://lilypond.org/"
LICENSE="GPL-3 FDL-1.3"
SLOT="0"
LANG_USE="l10n_ca l10n_cs l10n_de l10n_en l10n_fr l10n_hu l10n_it l10n_ja l10n_nl l10n_pt l10n_zh"
-IUSE="debug doc emacs profile vim-syntax ${LANG_USE}"
+IUSE="debug doc emacs profile ${LANG_USE}"
unset LANG_USE
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -64,19 +65,16 @@ PATCHES=(
DOCS=( DEDICATION README.md ROADMAP )
+# guile generates ELF files without use of C or machine code
+# It's a portage's false positive. bug #677600
+QA_PREBUILT='*[.]go'
+
src_prepare() {
default
- if ! use vim-syntax ; then
- sed -i 's/vim//' GNUmakefile.in || die
- fi
-
# respect CFLAGS
sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
- # remove bundled texinfo file (fixes bug #448560)
- rm Documentation/tex/texinfo.tex || die
-
eautoreconf
xdg_environment_reset #586592
@@ -102,6 +100,9 @@ src_configure() {
src_compile() {
default
+ # http://lilypond.org/doc/v2.24/Documentation/changes/index#notes-for-source-compilation-and-packagers
+ emake bytecode
+
use doc && emake LANGS="${L10N}" doc info
if use emacs ; then
@@ -111,7 +112,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+ emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install install-bytecode
use doc && emake DESTDIR="${D}" install-doc