summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/lilypond')
-rw-r--r--media-sound/lilypond/files/lilypond-9999-fix-font-size.patch13
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild4
2 files changed, 15 insertions, 2 deletions
diff --git a/media-sound/lilypond/files/lilypond-9999-fix-font-size.patch b/media-sound/lilypond/files/lilypond-9999-fix-font-size.patch
new file mode 100644
index 000000000000..45a3ad5e22ca
--- /dev/null
+++ b/media-sound/lilypond/files/lilypond-9999-fix-font-size.patch
@@ -0,0 +1,13 @@
+diff --git a/lily/pango-font.cc b/lily/pango-font.cc
+index 053ce17143..0c171bc44e 100644
+--- a/lily/pango-font.cc
++++ b/lily/pango-font.cc
+@@ -382,7 +382,7 @@ Pango_font::pango_item_string_stencil (PangoGlyphItem const *glyph_item) const
+ tail = SCM_CDRLOC (*tail);
+ }
+
+- PangoFontDescription *descr = pango_font_describe (pa->font);
++ PangoFontDescription *descr = pango_context_get_font_description (context_);
+ Real size = pango_font_description_get_size (descr)
+ / (static_cast<Real> (PANGO_SCALE));
+ pango_font_description_free (descr);
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index 89cf464d7f84..03ab64de7f8d 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -63,7 +63,7 @@ DEPEND="${RDEPEND}
RESTRICT="test"
PATCHES=(
- "${FILESDIR}"/${PN}-2.21.1-fix-font-size.patch
+ "${FILESDIR}"/${P}-fix-font-size.patch
)
DOCS=( DEDICATION HACKING README.md ROADMAP )