summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mixxx/files/mixxx-2.3.0-cmake.patch')
-rw-r--r--media-sound/mixxx/files/mixxx-2.3.0-cmake.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/media-sound/mixxx/files/mixxx-2.3.0-cmake.patch b/media-sound/mixxx/files/mixxx-2.3.0-cmake.patch
new file mode 100644
index 000000000000..b573a624d31e
--- /dev/null
+++ b/media-sound/mixxx/files/mixxx-2.3.0-cmake.patch
@@ -0,0 +1,11 @@
+--- mixxx-2.3.0/CMakeLists.txt
++++ mixxx-2.3.0/CMakeLists.txt
+@@ -53,8 +53,6 @@
+ set(CMAKE_BUILD_TYPE "${default_build_type}" CACHE STRING "Choose the type of build." FORCE)
+ # Set the possible values of build type for cmake-gui
+ set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS "Debug" "Release" "RelWithDebInfo")
+- elseif(NOT CMAKE_BUILD_TYPE MATCHES "^(Debug|Release|RelWithDebInfo)$")
+- message(FATAL_ERROR "CMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE} is not supported, use one of Debug, Release or RelWithDebInfo.")
+ endif()
+ endif()
+