summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mixxx')
-rw-r--r--media-sound/mixxx/mixxx-2.3.5-r1.ebuild (renamed from media-sound/mixxx/mixxx-2.3.5.ebuild)27
-rw-r--r--media-sound/mixxx/mixxx-2.3.9999.ebuild35
-rw-r--r--media-sound/mixxx/mixxx-9999.ebuild42
3 files changed, 41 insertions, 63 deletions
diff --git a/media-sound/mixxx/mixxx-2.3.5.ebuild b/media-sound/mixxx/mixxx-2.3.5-r1.ebuild
index 69c17499f146..c95ad499da23 100644
--- a/media-sound/mixxx/mixxx-2.3.5.ebuild
+++ b/media-sound/mixxx/mixxx-2.3.5-r1.ebuild
@@ -6,10 +6,10 @@ EAPI=8
inherit cmake xdg udev
DESCRIPTION="Advanced Digital DJ tool based on Qt"
-HOMEPAGE="https://www.mixxx.org/"
-if [[ "${PV}" == *9999 ]] ; then
+HOMEPAGE="https://mixxx.org/"
+if [[ ${PV} == *9999 ]] ; then
inherit git-r3
- if [[ "${PV}" == ?.?.9999 ]] ; then
+ if [[ ${PV} == ?.?.9999 ]] ; then
EGIT_BRANCH=${PV%.9999}
fi
EGIT_REPO_URI="https://github.com/mixxxdj/${PN}.git"
@@ -70,9 +70,9 @@ RDEPEND="
mp3? ( media-libs/libmad )
mp4? ( media-libs/libmp4v2:= )
opus? ( media-libs/opusfile )
- qtkeychain? ( dev-libs/qtkeychain )
+ qtkeychain? ( dev-libs/qtkeychain:=[qt5(+)] )
wavpack? ( media-sound/wavpack )
- "
+"
# libshout-idjc-2.4.6 is required. Please check and re-add once it's
# available in ::gentoo
# Meanwhile we're using the bundled libshout-idjc. See bug #775443
@@ -81,9 +81,11 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-qt/qtconcurrent:5
"
-BDEPEND="virtual/pkgconfig
+BDEPEND="
dev-qt/qttest:5
- dev-qt/qtxmlpatterns:5"
+ dev-qt/qtxmlpatterns:5
+ virtual/pkgconfig
+"
PATCHES=(
"${FILESDIR}"/${PN}-2.3.0-docs.patch
@@ -106,10 +108,6 @@ mixxx_set_globals() {
}
mixxx_set_globals
-src_prepare() {
- cmake_src_prepare
-}
-
src_configure() {
local mycmakeargs=(
# Not available on Linux yet and requires additional deps
@@ -131,19 +129,14 @@ src_configure() {
-DWAVPACK="$(usex wavpack on off)"
)
- if [[ "${PV}" == 9999 ]] ; then
+ if [[ ${PV} == 9999 ]] ; then
mycmakeargs+=(
-DENGINEPRIME="OFF"
-
)
fi
cmake_src_configure
}
-src_compile() {
- cmake_src_compile
-}
-
src_install() {
cmake_src_install
udev_newrules "${S}"/res/linux/mixxx-usb-uaccess.rules 69-mixxx-usb-uaccess.rules
diff --git a/media-sound/mixxx/mixxx-2.3.9999.ebuild b/media-sound/mixxx/mixxx-2.3.9999.ebuild
index eed827c69005..8e68e926a377 100644
--- a/media-sound/mixxx/mixxx-2.3.9999.ebuild
+++ b/media-sound/mixxx/mixxx-2.3.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,10 +6,10 @@ EAPI=8
inherit cmake xdg udev
DESCRIPTION="Advanced Digital DJ tool based on Qt"
-HOMEPAGE="https://www.mixxx.org/"
-if [[ "${PV}" == *9999 ]] ; then
+HOMEPAGE="https://mixxx.org/"
+if [[ ${PV} == *9999 ]] ; then
inherit git-r3
- if [[ "${PV}" == ?.?.9999 ]] ; then
+ if [[ ${PV} == ?.?.9999 ]] ; then
EGIT_BRANCH=${PV%.9999}
fi
EGIT_REPO_URI="https://github.com/mixxxdj/${PN}.git"
@@ -25,7 +25,7 @@ IUSE="aac ffmpeg hid keyfinder lv2 modplug mp3 mp4 opus qtkeychain shout wavpack
RDEPEND="
dev-db/sqlite
dev-libs/glib:2
- dev-libs/protobuf:0=
+ dev-libs/protobuf:=
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
@@ -70,9 +70,9 @@ RDEPEND="
mp3? ( media-libs/libmad )
mp4? ( media-libs/libmp4v2:= )
opus? ( media-libs/opusfile )
- qtkeychain? ( dev-libs/qtkeychain )
+ qtkeychain? ( dev-libs/qtkeychain:=[qt5(+)] )
wavpack? ( media-sound/wavpack )
- "
+"
# libshout-idjc-2.4.6 is required. Please check and re-add once it's
# available in ::gentoo
# Meanwhile we're using the bundled libshout-idjc. See bug #775443
@@ -81,13 +81,15 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-qt/qtconcurrent:5
"
-BDEPEND="virtual/pkgconfig
+BDEPEND="
dev-qt/qttest:5
- dev-qt/qtxmlpatterns:5"
+ dev-qt/qtxmlpatterns:5
+ virtual/pkgconfig
+"
PATCHES=(
- "${FILESDIR}"/mixxx-9999-docs.patch
- )
+ "${FILESDIR}"/${PN}-9999-docs.patch
+)
PLOCALES="
ca cs de en es fi fr gl id it ja kn nl pl pt ro ru sl sq sr tr zh-CN zh-TW
@@ -104,10 +106,6 @@ mixxx_set_globals() {
}
mixxx_set_globals
-src_prepare() {
- cmake_src_prepare
-}
-
src_configure() {
local mycmakeargs=(
# Not available on Linux yet and requires additional deps
@@ -129,19 +127,14 @@ src_configure() {
-DWAVPACK="$(usex wavpack on off)"
)
- if [[ "${PV}" == 9999 ]] ; then
+ if [[ ${PV} == 9999 ]] ; then
mycmakeargs+=(
-DENGINEPRIME="OFF"
-
)
fi
cmake_src_configure
}
-src_compile() {
- cmake_src_compile
-}
-
src_install() {
cmake_src_install
udev_newrules "${S}"/res/linux/mixxx-usb-uaccess.rules 69-mixxx-usb-uaccess.rules
diff --git a/media-sound/mixxx/mixxx-9999.ebuild b/media-sound/mixxx/mixxx-9999.ebuild
index d6ba056d0789..0447de377599 100644
--- a/media-sound/mixxx/mixxx-9999.ebuild
+++ b/media-sound/mixxx/mixxx-9999.ebuild
@@ -6,10 +6,10 @@ EAPI=8
inherit cmake xdg udev
DESCRIPTION="Advanced Digital DJ tool based on Qt"
-HOMEPAGE="https://www.mixxx.org/"
-if [[ "${PV}" == *9999 ]] ; then
+HOMEPAGE="https://mixxx.org/"
+if [[ ${PV} == *9999 ]] ; then
inherit git-r3
- if [[ "${PV}" == ?.?.9999 ]] ; then
+ if [[ ${PV} == ?.?.9999 ]] ; then
EGIT_BRANCH=${PV%.9999}
fi
EGIT_REPO_URI="https://github.com/mixxxdj/${PN}.git"
@@ -70,27 +70,24 @@ RDEPEND="
mp3? ( media-libs/libmad )
mp4? ( media-libs/libmp4v2:= )
opus? ( media-libs/opusfile )
- qtkeychain? ( dev-libs/qtkeychain )
+ qtkeychain? ( dev-libs/qtkeychain:=[qt5(+)] )
shout? ( >=media-libs/libshout-2.4.5 )
wavpack? ( media-sound/wavpack )
- "
-
+"
DEPEND="${RDEPEND}
- dev-cpp/ms-gsl"
-BDEPEND="virtual/pkgconfig
+ dev-cpp/ms-gsl
+"
+BDEPEND="
dev-qt/qttest:5
- dev-qt/qtxmlpatterns:5"
+ dev-qt/qtxmlpatterns:5
+ virtual/pkgconfig
+"
PATCHES=(
- "${FILESDIR}"/mixxx-9999-docs.patch
- )
-
-src_prepare() {
- cmake_src_prepare
-}
+ "${FILESDIR}"/${PN}-9999-docs.patch
+)
src_configure() {
-
local mycmakeargs=(
-DFAAD="$(usex aac on off)"
-DFFMPEG="$(usex ffmpeg on off)"
@@ -110,19 +107,14 @@ src_configure() {
-DBUILD_SHARED_LIBS=OFF
)
- if [[ "${PV}" == 9999 ]] ; then
- local mycmakeargs+=(
- -DENGINEPRIME="OFF"
-
- )
+ if [[ ${PV} == 9999 ]] ; then
+ mycmakeargs+=(
+ -DENGINEPRIME="OFF"
+ )
fi
cmake_src_configure
}
-src_compile() {
- cmake_src_compile
-}
-
src_install() {
cmake_src_install
udev_newrules "${S}"/res/linux/mixxx-usb-uaccess.rules 69-mixxx-usb-uaccess.rules