summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pavucontrol/pavucontrol-4.0.ebuild')
-rw-r--r--media-sound/pavucontrol/pavucontrol-4.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/pavucontrol/pavucontrol-4.0.ebuild b/media-sound/pavucontrol/pavucontrol-4.0.ebuild
new file mode 100644
index 000000000000..8291e6f1a184
--- /dev/null
+++ b/media-sound/pavucontrol/pavucontrol-4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="Pulseaudio Volume Control, GTK based mixer for Pulseaudio"
+HOMEPAGE="https://freedesktop.org/software/pulseaudio/pavucontrol/"
+SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="
+ >=dev-cpp/gtkmm-3.0:3.0
+ >=dev-libs/libsigc++-2.2:2
+ >=media-libs/libcanberra-0.16[gtk3]
+ >=media-sound/pulseaudio-5[glib]
+ virtual/freedesktop-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+src_configure() {
+ append-cxxflags -std=c++11 #567216
+ local myeconfargs=(
+ --disable-lynx
+ --docdir=/usr/share/doc/${PF}
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}