summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/rexima')
-rw-r--r--media-sound/rexima/Manifest1
-rw-r--r--media-sound/rexima/metadata.xml5
-rw-r--r--media-sound/rexima/rexima-1.4.ebuild30
3 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/rexima/Manifest b/media-sound/rexima/Manifest
new file mode 100644
index 000000000000..709321941e97
--- /dev/null
+++ b/media-sound/rexima/Manifest
@@ -0,0 +1 @@
+DIST rexima-1.4.tar.gz 15903 SHA256 bd5192bc12b6e3b1149cb936403fddba7985628ae85d9d08f6a79f2aca35bde6
diff --git a/media-sound/rexima/metadata.xml b/media-sound/rexima/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/rexima/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/rexima/rexima-1.4.ebuild b/media-sound/rexima/rexima-1.4.ebuild
new file mode 100644
index 000000000000..c534bdae8631
--- /dev/null
+++ b/media-sound/rexima/rexima-1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="A curses-based interactive mixer which can also be used from the command-line"
+HOMEPAGE="http://www.svgalib.org/rus/rexima.html"
+SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/apps/sound/mixers/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+ echo "LDLIBS=-lncurses" > Makefile
+ echo "all: rexima" >> Makefile
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin rexima || die
+ doman rexima.1 || die
+ dodoc NEWS README ChangeLog
+}