summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/splay/splay-0.9.5.2-r2.ebuild')
-rw-r--r--media-sound/splay/splay-0.9.5.2-r2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-sound/splay/splay-0.9.5.2-r2.ebuild b/media-sound/splay/splay-0.9.5.2-r2.ebuild
index b66657bceebf..df9a369f7c09 100644
--- a/media-sound/splay/splay-0.9.5.2-r2.ebuild
+++ b/media-sound/splay/splay-0.9.5.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="An audio player, primarily for the console"
HOMEPAGE="http://splay.sourceforge.net/"
@@ -28,3 +28,9 @@ src_prepare() {
mv configure.{in,ac} || die
eautoreconf
}
+
+src_configure() {
+ append-cxxflags -std=c++14
+
+ default
+}