summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/vimpc/vimpc-9999.ebuild')
-rw-r--r--media-sound/vimpc/vimpc-9999.ebuild37
1 files changed, 26 insertions, 11 deletions
diff --git a/media-sound/vimpc/vimpc-9999.ebuild b/media-sound/vimpc/vimpc-9999.ebuild
index 5d7ee52d0a6e..a6a60a208193 100644
--- a/media-sound/vimpc/vimpc-9999.ebuild
+++ b/media-sound/vimpc/vimpc-9999.ebuild
@@ -1,26 +1,37 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools git-r3
+inherit autotools
-DESCRIPTION="An ncurses based mpd client with vi like key bindings"
+DESCRIPTION="An ncurses based mpd client with vi-like key bindings"
HOMEPAGE="https://github.com/boysetsfrog/vimpc"
-EGIT_REPO_URI="https://github.com/boysetsfrog/${PN}.git"
-
-LICENSE="GPL-3"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/boysetsfrog/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/boysetsfrog/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
SLOT="0"
IUSE="boost taglib"
-RDEPEND="dev-libs/libpcre
+RDEPEND="
+ dev-libs/libpcre
media-libs/libmpdclient
boost? ( dev-libs/boost:= )
- taglib? ( media-libs/taglib )"
+ taglib? ( media-libs/taglib )
+"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-DOCS=( AUTHORS README.md doc/vimpcrc.example )
+PATCHES=(
+ "${FILESDIR}"/${P}-boost.patch
+ "${FILESDIR}"/${P}-wformat-security.patch
+)
src_prepare() {
default
@@ -28,12 +39,16 @@ src_prepare() {
}
src_configure() {
+ # Tests here seem to make cppunit linked into the main vimpc binary
+ # Not clear how to run them either
econf \
$(use_enable boost) \
- $(use_enable taglib)
+ $(use_enable taglib) \
+ --disable-test
}
src_install() {
+ local DOCS=( AUTHORS README.md doc/vimpcrc.example )
default
# vimpc will look for help.txt