summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ardour/ardour-7.5-r2.ebuild (renamed from media-sound/ardour/ardour-7.5-r1.ebuild)9
1 files changed, 9 insertions, 0 deletions
diff --git a/media-sound/ardour/ardour-7.5-r1.ebuild b/media-sound/ardour/ardour-7.5-r2.ebuild
index c68a856a7726..82c6d9e313d4 100644
--- a/media-sound/ardour/ardour-7.5-r1.ebuild
+++ b/media-sound/ardour/ardour-7.5-r2.ebuild
@@ -88,7 +88,10 @@ pkg_setup() {
src_prepare() {
default
+ # delete optimization flags
sed 's/'full-optimization\'\ :\ \\[.*'/'full-optimization\'\ :\ \'\','/' -i "${S}"/wscript || die
+
+ # handle arch
MARCH=$(get-flag march)
OPTFLAGS=""
if use cpu_flags_x86_sse; then
@@ -110,9 +113,13 @@ src_prepare() {
sed 's/flag_line\ =\ o.*/flag_line\ =\ \": '"${OPTFLAGS}"' just some place holders\"/' \
-i "${S}"/wscript || die
sed 's/cpu\ ==\ .*/cpu\ ==\ "LeaveMarchAsIs":/' -i "${S}"/wscript || die
+
+ # boost and shebang
append-flags "-lboost_system"
python_fix_shebang "${S}"/wscript
python_fix_shebang "${S}"/waf
+
+ # handle locales
my_lcmsg() {
rm -f {gtk2_ardour,gtk2_ardour/appdata,libs/ardour,libs/gtkmm2ext}/po/${1}.po
}
@@ -140,6 +147,7 @@ src_configure() {
$(usex nls "--nls" "--no-nls")
$(usex phonehome "--phone-home" "--no-phone-home")
# not possible right now --use-external-libs
+ # missing dependency: https://github.com/c4dm/qm-dsp
)
waf-utils_src_configure "${myconf[@]}"
@@ -173,6 +181,7 @@ src_install() {
insinto /usr/share/mime/packages
newins build/gtk2_ardour/ardour.xml ardour${SLOT}.xml
+ rm "${D}/usr/share/mime/packages/ardour.xml" || die
}
pkg_postinst() {