summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pamix/Manifest1
-rw-r--r--media-sound/pamix/pamix-1.2.ebuild30
-rw-r--r--media-sound/pamix/pamix-9999.ebuild10
3 files changed, 40 insertions, 1 deletions
diff --git a/media-sound/pamix/Manifest b/media-sound/pamix/Manifest
index e696d39d74b3..689c6aee798c 100644
--- a/media-sound/pamix/Manifest
+++ b/media-sound/pamix/Manifest
@@ -1 +1,2 @@
DIST pamix-1.1.tar.gz 7955 SHA256 81e88b5c305b2864ea5c6adda79a9a2fe18c7ed7721354e865862e779acb6f5f SHA512 cdec746bfbb1887d558762a0247370616f480b4695a7802f4ac47c7d9f545efe77af228b1992dd61e2bed09118ca095546bde206be4b8dfea1839b91c768cdbc WHIRLPOOL c1113e4783637c1ec5f77be735d4a96ffc3060449571ad3f32d06e9d369c7dba6140863ab5b2f0a19f78b7a591614c32980e1e87c8ec950fe3e589514e5759a2
+DIST pamix-1.2.tar.gz 9907 SHA256 4da3a60376cfb3eb2863743782cbb4a2d3a18a336ec45f6a33e93f17cde8f149 SHA512 af368778bd731c0887c5a01f5c6f3010f56600eaaf68e13e0ff38b4e484ac24ad094df0b3607c5fdb4517e48cb196cc235462a5e83b4ced00d06d821222bd1c6 WHIRLPOOL b4624e3b0452856d423ed19868bfb70e7fe8bd7ced0688295210261514e45bee85aaa445933cd43fe5a7cad62901ea7b16d76c9f53f978a502228881da5d2002
diff --git a/media-sound/pamix/pamix-1.2.ebuild b/media-sound/pamix/pamix-1.2.ebuild
new file mode 100644
index 000000000000..986dad71c324
--- /dev/null
+++ b/media-sound/pamix/pamix-1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+[[ "${PV}" == 9999 ]] && inherit git-r3
+
+DESCRIPTION="A PulseAudio NCurses mixer"
+HOMEPAGE="https://github.com/patroclos/PAmix"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/patroclos/PAmix.git"
+else
+ SRC_URI="https://github.com/patroclos/PAmix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/PAmix-${PV}"
+fi
+
+RDEPEND="media-sound/pulseaudio
+ sys-libs/ncurses:0=[unicode]"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_unpack() {
+ [[ "${PV}" == 9999 ]] && git-r3_src_unpack
+ default
+}
diff --git a/media-sound/pamix/pamix-9999.ebuild b/media-sound/pamix/pamix-9999.ebuild
index 986dad71c324..97f3fe1c284b 100644
--- a/media-sound/pamix/pamix-9999.ebuild
+++ b/media-sound/pamix/pamix-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-[[ "${PV}" == 9999 ]] && inherit git-r3
+[[ "${PV}" == 9999 ]] && inherit autotools git-r3
DESCRIPTION="A PulseAudio NCurses mixer"
HOMEPAGE="https://github.com/patroclos/PAmix"
@@ -28,3 +28,11 @@ src_unpack() {
[[ "${PV}" == 9999 ]] && git-r3_src_unpack
default
}
+
+src_prepare() {
+ default
+ if [[ "${PV}" == 9999 ]] ; then
+ sed 's@^pamix_LDFLAGS@pamix_LDADD@' -i Makefile.am || die
+ eautoreconf
+ fi
+}