summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pianobooster/files/pianobooster-0.6.4b-underlinking.patch15
-rw-r--r--media-sound/pianobooster/pianobooster-0.6.4b.ebuild9
2 files changed, 21 insertions, 3 deletions
diff --git a/media-sound/pianobooster/files/pianobooster-0.6.4b-underlinking.patch b/media-sound/pianobooster/files/pianobooster-0.6.4b-underlinking.patch
new file mode 100644
index 000000000000..37720e534a3d
--- /dev/null
+++ b/media-sound/pianobooster/files/pianobooster-0.6.4b-underlinking.patch
@@ -0,0 +1,15 @@
+Fix build failure caused by underlinking.
+
+Gentoo-bug: 369697
+
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -57,6 +57,8 @@
+ #IF(ALSA_FOUND)
+ ADD_DEFINITIONS(-D__LINUX_ALSASEQ__)
+ LINK_LIBRARIES (asound)
++ LINK_LIBRARIES (GL)
++ LINK_LIBRARIES (pthread)
+ #ELSE(ALSA_FOUND)
+ # MESSAGE(FATAL_ERROR "Please install the 'libasound2-dev' package and then try again")
+ #ENDIF(ALSA_FOUND)
diff --git a/media-sound/pianobooster/pianobooster-0.6.4b.ebuild b/media-sound/pianobooster/pianobooster-0.6.4b.ebuild
index 54705c9f72be..8da3fe2ed96a 100644
--- a/media-sound/pianobooster/pianobooster-0.6.4b.ebuild
+++ b/media-sound/pianobooster/pianobooster-0.6.4b.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,8 +26,11 @@ RDEPEND="${DEPEND}"
DOCS="ReleaseNote.txt ../README.txt"
-PATCHES=( "${FILESDIR}"/${P}-cmake.patch
- "${FILESDIR}"/${P}-gcc47.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-underlinking.patch
+)
S=${WORKDIR}/${MY_P}/src