summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/gnump3d/files/gnump3d.init.d-r140
-rw-r--r--media-sound/gnump3d/gnump3d-3.0-r4.ebuild76
2 files changed, 116 insertions, 0 deletions
diff --git a/media-sound/gnump3d/files/gnump3d.init.d-r1 b/media-sound/gnump3d/files/gnump3d.init.d-r1
new file mode 100644
index 000000000000..2ead467d7882
--- /dev/null
+++ b/media-sound/gnump3d/files/gnump3d.init.d-r1
@@ -0,0 +1,40 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+extra_commands="index"
+
+depend() {
+ need net
+ after netmount nfsmount
+}
+
+start() {
+ ebegin "Starting gnump3d"
+
+ if [ ${DO_INDEX} -eq 1 ]; then
+ ebegin "Updating index of music files (may take a while for the first time)"
+ /usr/bin/gnump3d-index
+ eend $?
+ fi
+
+ start-stop-daemon --start --quiet --exec /usr/bin/gnump3d2 --make-pidfile \
+ --pidfile /var/run/gnump3d.pid --background -- --quiet
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping gnump3d"
+ start-stop-daemon --stop --quiet --pidfile /var/run/gnump3d.pid
+ eend $?
+}
+
+index() {
+ ebegin "Indexing music files"
+ /usr/bin/gnump3d-index
+ eend $?
+}
+
+start_pre() {
+ checkpath -d -o "gnump3d:gnump3d" -q "/var/cache/gnump3d" "/var/cache/gnump3d/serving"
+}
diff --git a/media-sound/gnump3d/gnump3d-3.0-r4.ebuild b/media-sound/gnump3d/gnump3d-3.0-r4.ebuild
new file mode 100644
index 000000000000..fc1a65587ece
--- /dev/null
+++ b/media-sound/gnump3d/gnump3d-3.0-r4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib perl-module
+
+DESCRIPTION="A streaming server for MP3, OGG vorbis and other streamable files"
+HOMEPAGE="https://www.gnu.org/software/gnump3d/"
+SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ppc64 sparc x86"
+IUSE="sox"
+
+DEPEND="
+ acct-group/gnump3d
+ acct-user/gnump3d
+"
+
+RDEPEND="
+ ${DEPEND}
+ sox? ( media-sound/sox )
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ LIBDIR=/usr/$(get_libdir)
+}
+
+src_compile() { :; }
+
+src_install() {
+ perl_set_version
+
+ insinto "${VENDOR_LIB}"/gnump3d
+ doins lib/gnump3d/*.pm
+ insinto "${VENDOR_LIB}"/gnump3d/plugins
+ doins lib/gnump3d/plugins/*.pm
+ insinto "${VENDOR_LIB}"/gnump3d/lang
+ doins lib/gnump3d/lang/*.pm
+
+ dobin bin/gnump3d2 bin/gnump3d-top bin/gnump3d-index
+ dosym /usr/bin/gnump3d2 /usr/bin/gnump3d
+ doman man/*.1
+
+ insinto /usr/share/gnump3d
+ doins -r templates/*
+
+ insinto /etc/gnump3d
+ doins etc/gnump3d.conf etc/mime.types etc/file.types
+ sed -e "s,PLUGINDIR,${VENDOR_LIB},g" -i "${ED}/etc/gnump3d/gnump3d.conf" || die
+ sed -e 's,^user *= *\(.*\)$,user = gnump3d,g' -i "${ED}/etc/gnump3d/gnump3d.conf" || die
+
+ dodoc AUTHORS ChangeLog DOWNSAMPLING PLUGINS README SUPPORT TODO
+
+ newinitd "${FILESDIR}"/${PN}.init.d-r1 gnump3d
+ newconfd "${FILESDIR}"/${PN}.conf.d gnump3d
+
+ keepdir /var/log/gnump3d
+ fowners gnump3d:gnump3d /var/log/gnump3d
+}
+
+pkg_postinst() {
+ elog "Please edit your /etc/gnump3d/gnump3d.conf before running"
+ elog "/etc/init.d/gnump3d start"
+ elog ""
+ elog "At the very least, you will need to change the root directory"
+ elog "where music is found. By default, gnump3d will also listen"
+ elog "to any address on port 8888"
+ elog ""
+ elog "You can optionally use sox to downmix the quality of streamed"
+ elog "music in realtime for slow connections."
+}