summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/cclive')
-rw-r--r--media-video/cclive/cclive-0.9.3-r2.ebuild5
-rw-r--r--media-video/cclive/files/cclive-0.9.3-boost-1.67.patch13
2 files changed, 16 insertions, 2 deletions
diff --git a/media-video/cclive/cclive-0.9.3-r2.ebuild b/media-video/cclive/cclive-0.9.3-r2.ebuild
index 36533f233014..208372b4da9d 100644
--- a/media-video/cclive/cclive-0.9.3-r2.ebuild
+++ b/media-video/cclive/cclive-0.9.3-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic
@@ -27,6 +27,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-iostream.patch #527658
"${FILESDIR}"/${P}-boost-ver-check.patch #548310
+ "${FILESDIR}"/${P}-boost-1.67.patch #671768
)
src_configure() {
diff --git a/media-video/cclive/files/cclive-0.9.3-boost-1.67.patch b/media-video/cclive/files/cclive-0.9.3-boost-1.67.patch
new file mode 100644
index 000000000000..7eecb491a5b5
--- /dev/null
+++ b/media-video/cclive/files/cclive-0.9.3-boost-1.67.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/671768
+
+--- a/src/cc/progressbar.h
++++ b/src/cc/progressbar.h
+@@ -316,7 +316,7 @@ private:
+
+ static inline std::string eta_from_seconds(const double s)
+ {
+- const pt::time_duration& td = pt::seconds(s);
++ const pt::time_duration& td = pt::seconds(long(s));
+ return pt::to_simple_string(td);
+ }
+