summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/h264enc/h264enc-10.4.1.ebuild')
-rw-r--r--media-video/h264enc/h264enc-10.4.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-video/h264enc/h264enc-10.4.1.ebuild b/media-video/h264enc/h264enc-10.4.1.ebuild
new file mode 100644
index 000000000000..d17ea6e23726
--- /dev/null
+++ b/media-video/h264enc/h264enc-10.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Script to encode H.264/AVC/MPEG-4 Part 10 formats"
+HOMEPAGE="http://h264enc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aac dvd flac lame matroska mp4 ogm vorbis"
+
+RDEPEND="
+ media-video/mplayer[encode,x264]
+ sys-apps/coreutils
+ sys-apps/pv
+ sys-devel/bc
+ sys-process/time
+ aac? (
+ media-libs/faac
+ media-sound/aacplusenc )
+ dvd? ( media-video/lsdvd )
+ flac? ( media-libs/flac )
+ lame? ( media-sound/lame )
+ matroska? ( media-video/mkvtoolnix )
+ mp4? ( >=media-video/gpac-0.4.5[a52] )
+ ogm? ( media-sound/ogmtools )
+ vorbis? ( media-sound/vorbis-tools )"
+DEPEND=""
+
+src_install() {
+ dobin ${PN}
+ doman man/${PN}.1
+ dodoc doc/*
+ docinto matrices
+ dodoc matrices/*
+}