summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/lsdvd/files')
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-chapter-count.patch25
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-newline.patch22
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-title.patch27
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-types.patch27
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-usec.patch21
5 files changed, 0 insertions, 122 deletions
diff --git a/media-video/lsdvd/files/lsdvd-0.16-chapter-count.patch b/media-video/lsdvd/files/lsdvd-0.16-chapter-count.patch
deleted file mode 100644
index f51bd03762fc..000000000000
--- a/media-video/lsdvd/files/lsdvd-0.16-chapter-count.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Using tt_srpt->title[].nr_of_ptts from the VMG IFO as a reference to the
-chapter count is often wrong, and noted as such in the source code. Use
-the program chain instead.
-
---- lsdvd-0.16/lsdvd.c.orig 2014-08-22 21:47:06.009490680 -0600
-+++ lsdvd-0.16/lsdvd.c 2014-08-22 21:47:30.947257942 -0600
-@@ -347,6 +347,7 @@
- }
-
- dvd_info.titles[j].chapter_count_reported = ifo_zero->tt_srpt->title[j].nr_of_ptts;
-+ dvd_info.titles[j].chapter_count = pgc->nr_of_programs;
- dvd_info.titles[j].cell_count = pgc->nr_of_cells;
- dvd_info.titles[j].audiostream_count = vtsi_mat->nr_of_vts_audio_streams;
- dvd_info.titles[j].subtitle_count = vtsi_mat->nr_of_vts_subp_streams;
---- lsdvd-0.16/ohuman.c.orig 2014-08-22 21:47:00.993538145 -0600
-+++ lsdvd-0.16/ohuman.c 2014-08-22 21:47:45.533121749 -0600
-@@ -20,7 +20,7 @@
- // (int)(dvd_info->titles[j].general.length / 60) % 60,
- // (float)((int)(dvd_info->titles[j].general.length * 1000) % 6000) / 1000); //,
- // dvd_info->titles[j].general.length);
-- printf("Chapters: %02d, Cells: %02d, ", dvd_info->titles[j].chapter_count_reported, dvd_info->titles[j].cell_count);
-+ printf("Chapters: %02d, Cells: %02d, ", dvd_info->titles[j].chapter_count, dvd_info->titles[j].cell_count);
- printf("Audio streams: %02d, Subpictures: %02d", dvd_info->titles[j].audiostream_count, dvd_info->titles[j].subtitle_count);
- printf("\n");
-
diff --git a/media-video/lsdvd/files/lsdvd-0.16-newline.patch b/media-video/lsdvd/files/lsdvd-0.16-newline.patch
deleted file mode 100644
index 4f0ec1a74cd4..000000000000
--- a/media-video/lsdvd/files/lsdvd-0.16-newline.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Removes extra newline from output like this:
-
-Title: 01, Length: 02:18:41.834 Chapters: 06, Cells: 06, Audio streams: 01, Subpictures: 03
-
-Title: 02, Length: 00:46:16.000 Chapters: 03, Cells: 03, Audio streams: 01, Subpictures: 03
-
-Title: 03, Length: 00:46:11.834 Chapters: 03, Cells: 03, Audio streams: 01, Subpictures: 03
---- lsdvd-0.16/ohuman.c.orig 2014-08-22 21:47:00.993538145 -0600
-+++ lsdvd-0.16/ohuman.c 2014-08-22 21:52:11.964633226 -0600
-@@ -111,11 +111,10 @@
- printf("\n");
- }
- }
-- printf("\n");
- }
- }
-
- if (! opt_t) {
-- printf("Longest track: %02d\n\n", dvd_info->longest_track);
-+ printf("Longest track: %02d\n", dvd_info->longest_track);
- }
- }
diff --git a/media-video/lsdvd/files/lsdvd-0.16-title.patch b/media-video/lsdvd/files/lsdvd-0.16-title.patch
deleted file mode 100644
index 44511a126e64..000000000000
--- a/media-video/lsdvd/files/lsdvd-0.16-title.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-See, http://bugs.gentoo.org/show_bug.cgi?id=233113
-
-lsdvd always reads the infos for all titles (even if only a single title was
-selected with "-t") and bails out if there is an error.
-
-Now, if for example title 5 is unreadable but you're interested in title 1, you
-should be able to get the info by using "-t 1", but that doesn't work, as lsdvd
-errors out before even starting the output because it can't read title 5.
-
-To solve this my patch makes lsdvd ignore read errors in titles it wouldn't
-display anyway.
-
-Patch by Martin Thierer
-
-diff -uw lsdvd-0.16.orig/lsdvd.c lsdvd-0.16/lsdvd.c
---- lsdvd-0.16.orig/lsdvd.c 2006-03-02 14:48:11.000000000 +0100
-+++ lsdvd-0.16/lsdvd.c 2008-07-27 20:11:55.000000000 +0200
-@@ -292,7 +292,7 @@
-
- for (i=1; i <= ifo_zero->vts_atrt->nr_of_vtss; i++) {
- ifo[i] = ifoOpen(dvd, i);
-- if ( !ifo[i] ) {
-+ if ( !ifo[i] && opt_t == i ) {
- fprintf( stderr, "Can't open ifo %d!\n", i);
- return 4;
- }
-
diff --git a/media-video/lsdvd/files/lsdvd-0.16-types.patch b/media-video/lsdvd/files/lsdvd-0.16-types.patch
deleted file mode 100644
index b20f8ea2cb4b..000000000000
--- a/media-video/lsdvd/files/lsdvd-0.16-types.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: lsdvd-0.16/configure.in
-===================================================================
---- lsdvd-0.16.orig/configure.in
-+++ lsdvd-0.16/configure.in
-@@ -10,8 +10,8 @@ fi
-
- AC_CHECK_LIB(dvdread, DVDOpen, , AC_MSG_ERROR([libdvdread not found!]))
- AC_MSG_CHECKING([for dvdread/ifo_read.h])
--AC_TRY_COMPILE([#include <dvdread/ifo_read.h>
-- #include <stdint.h>], ,
-+AC_TRY_COMPILE([#include <stdint.h>
-+ #include <dvdread/ifo_read.h>], ,
- AC_MSG_RESULT([yes]),
- AC_MSG_RESULT([no])
- AC_MSG_ERROR([Header files for dvdread not found]))
-Index: lsdvd-0.16/lsdvd.c
-===================================================================
---- lsdvd-0.16.orig/lsdvd.c
-+++ lsdvd-0.16/lsdvd.c
-@@ -13,6 +13,7 @@
- * 2003-04-19 Cleanups get_title_name, added dvdtime2msec, added helper macros,
- * output info structures in form of a Perl module, by Henk Vergonet.
- */
-+#include <stdint.h>
- #include <dvdread/ifo_read.h>
- #include <string.h>
- #include <sys/stat.h>
diff --git a/media-video/lsdvd/files/lsdvd-0.16-usec.patch b/media-video/lsdvd/files/lsdvd-0.16-usec.patch
deleted file mode 100644
index bfaa16e9615d..000000000000
--- a/media-video/lsdvd/files/lsdvd-0.16-usec.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -uw lsdvd-0.16.orig/lsdvd.c lsdvd-0.16/lsdvd.c
---- lsdvd-0.16.orig/lsdvd.c 2006-03-02 14:48:11.000000000 +0100
-+++ lsdvd-0.16/lsdvd.c 2008-05-18 13:58:15.000000000 +0200
-@@ -92,7 +92,7 @@
- ms += (((dt->second & 0xf0) >> 3) * 5 + (dt->second & 0x0f)) * 1000;
-
- if(fps > 0)
-- ms += ((dt->frame_u & 0x30) >> 3) * 5 + (dt->frame_u & 0x0f) * 1000.0 / fps;
-+ ms += (((dt->frame_u & 0x30) >> 3) * 5 + (dt->frame_u & 0x0f)) * 1000.0 / fps;
-
- return ms;
- }
-@@ -107,7 +107,7 @@
- {
- double fps = frames_per_s[(dt->frame_u & 0xc0) >> 6];
-
-- pt->usec = pt->usec + ((dt->frame_u & 0x30) >> 3) * 5 + (dt->frame_u & 0x0f) * 1000.0 / fps;
-+ pt->usec = pt->usec + (((dt->frame_u & 0x30) >> 3) * 5 + (dt->frame_u & 0x0f)) * 1000.0 / fps;
- pt->second = pt->second + ((dt->second & 0xf0) >> 3) * 5 + (dt->second & 0x0f);
- pt->minute = pt->minute + ((dt->minute & 0xf0) >> 3) * 5 + (dt->minute & 0x0f);
- pt->hour = pt->hour + ((dt->hour & 0xf0) >> 3) * 5 + (dt->hour & 0x0f);