summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mkvtoolnix/mkvtoolnix-9999.ebuild')
-rw-r--r--media-video/mkvtoolnix/mkvtoolnix-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/media-video/mkvtoolnix/mkvtoolnix-9999.ebuild b/media-video/mkvtoolnix/mkvtoolnix-9999.ebuild
index 4f1a6f2c0455..7456a1ad02d0 100644
--- a/media-video/mkvtoolnix/mkvtoolnix-9999.ebuild
+++ b/media-video/mkvtoolnix/mkvtoolnix-9999.ebuild
@@ -3,12 +3,12 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs multiprocessing qmake-utils xdg
+inherit autotools flag-o-matic toolchain-funcs multiprocessing qmake-utils xdg
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://gitlab.com/mbunkus/mkvtoolnix.git"
EGIT_SUBMODULES=()
- inherit autotools git-r3
+ inherit git-r3
else
SRC_URI="https://mkvtoolnix.download/sources/${P}.tar.xz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
@@ -19,7 +19,7 @@ HOMEPAGE="https://mkvtoolnix.download/ https://gitlab.com/mbunkus/mkvtoolnix"
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug dvd nls pch test qt5"
+IUSE="dbus debug dvd nls pch qt5 test"
RESTRICT="!test? ( test )"
# check NEWS.md for build system changes entries for boost/libebml/libmatroska
@@ -38,13 +38,13 @@ RDEPEND="
dvd? ( media-libs/libdvdread:= )
qt5? (
dev-qt/qtcore:5
- dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
dev-qt/qtconcurrent:5
dev-qt/qtmultimedia:5
app-text/cmark:0=
+ dbus? ( dev-qt/qtdbus:5 )
)
"
DEPEND="${RDEPEND}
@@ -63,12 +63,16 @@ BDEPEND="
)
"
+PATCHES=( "${FILESDIR}"/mkvtoolnix-49.0.0-qt5dbus.patch )
+
src_prepare() {
xdg_src_prepare
if [[ ${PV} == *9999 ]]; then
./autogen.sh || die
fi
+ eautoreconf
+
# remove bundled libs
rm -r lib/{fmt,libebml,libmatroska,nlohmann-json,pugixml,utf8-cpp} || die
}
@@ -80,6 +84,7 @@ src_configure() {
local myeconfargs=(
$(use_enable debug)
$(usex pch "" --disable-precompiled-headers)
+ $(use_enable dbus)
$(use_enable qt5 qt)
$(use_with dvd dvdread)
$(use_with nls gettext)