summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mpglen/mpglen-0.1.ebuild')
-rw-r--r--media-video/mpglen/mpglen-0.1.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/media-video/mpglen/mpglen-0.1.ebuild b/media-video/mpglen/mpglen-0.1.ebuild
index 0da5b94f898a..d366cc724bfa 100644
--- a/media-video/mpglen/mpglen-0.1.ebuild
+++ b/media-video/mpglen/mpglen-0.1.ebuild
@@ -1,34 +1,37 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit flag-o-matic toolchain-funcs
DESCRIPTION="A program to scan through a MPEG file and count the number of GOPs and frames"
HOMEPAGE="http://www.iamnota.net/mpglen/"
-SRC_URI="http://www.iamnota.net/mpglen/${PN}.tar.gz"
+SRC_URI="mirror://gentoo/${PN}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- echo 'all: mpglen' > Makefile
+src_prepare() {
+ default
+
+ # awful Makefile, just rely on implicit rules
+ rm Makefile || die
+}
+
+src_configure() {
append-lfs-flags
+ tc-export CC
}
src_compile() {
- tc-export CC
- emake || die "emake failed"
+ emake mpglen
}
src_install () {
- dobin ${PN} || die
+ dobin ${PN}
dodoc AUTHORS Changelog README
}