summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/omxplayer/omxplayer-9999.ebuild')
-rw-r--r--media-video/omxplayer/omxplayer-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-video/omxplayer/omxplayer-9999.ebuild b/media-video/omxplayer/omxplayer-9999.ebuild
new file mode 100644
index 000000000000..88ac4d327fef
--- /dev/null
+++ b/media-video/omxplayer/omxplayer-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils git-r3 toolchain-funcs flag-o-matic
+
+DESCRIPTION="Command line media player for the Raspberry Pi"
+HOMEPAGE="https://github.com/popcornmix/omxplayer"
+EGIT_REPO_URI="https://github.com/popcornmix/omxplayer.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-libs/libpcre
+ media-fonts/freefont
+ || ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin )
+ sys-apps/dbus
+ sys-apps/fbset
+ virtual/ffmpeg
+ x11-apps/xrefresh
+ x11-apps/xset"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-9999-Makefile.patch \
+ "${FILESDIR}"/fonts-path.patch
+
+ cat > Makefile.include << EOF
+LIBS=-lvchiq_arm -lvcos -lbcm_host -lEGL -lGLESv2 -lopenmaxil -lrt -lpthread
+EOF
+
+ tc-export CXX
+}
+
+src_compile() {
+ emake ${PN}.bin
+}
+
+src_install() {
+ dobin ${PN} ${PN}.bin
+ dodoc README.md
+}