summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/openshot/openshot-2.6.1.ebuild')
-rw-r--r--media-video/openshot/openshot-2.6.1.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/media-video/openshot/openshot-2.6.1.ebuild b/media-video/openshot/openshot-2.6.1.ebuild
index 48be05d13972..a013ab34e233 100644
--- a/media-video/openshot/openshot-2.6.1.ebuild
+++ b/media-video/openshot/openshot-2.6.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
-PYTHON_REQ_USE=xml
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1 xdg
@@ -18,20 +18,20 @@ S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="GPL-3+"
SLOT="1"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE="doc"
RDEPEND="$(python_gen_cond_dep '
- dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
- dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,svg,widgets]
- dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
- dev-python/pyzmq[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,svg,widgets]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
')
>=media-libs/libopenshot-0.2.7:0=[python,${PYTHON_SINGLE_USEDEP}]"
DEPEND=""
BDEPEND="$(python_gen_cond_dep '
- doc? ( dev-python/sphinx[${PYTHON_MULTI_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
')"
src_prepare() {
@@ -44,12 +44,12 @@ python_compile_all() {
use doc && emake -C doc html
}
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}
-
python_test() {
distutils_install_for_testing
"${EPYTHON}" src/tests/query_tests.py -v --platform minimal || die
}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}