summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/rage/rage-0.4.0-r1.ebuild')
-rw-r--r--media-video/rage/rage-0.4.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-video/rage/rage-0.4.0-r1.ebuild b/media-video/rage/rage-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..b3e1a1ba5b0f
--- /dev/null
+++ b/media-video/rage/rage-0.4.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Video and audio player written using EFL"
+HOMEPAGE="https://www.enlightenment.org/about-rage"
+SRC_URI="https://download.enlightenment.org/rel/apps/rage/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ >=dev-libs/efl-1.26.1[gstreamer]
+ media-plugins/gst-plugins-meta[ffmpeg]"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "Control your media file support with media-plugins/gst-plugins-meta[*]"
+ elog "and/or media-video/ffmpeg[*]"
+}