summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/rtmpdump/rtmpdump-9999.ebuild')
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild47
1 files changed, 21 insertions, 26 deletions
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
index 4e6b50ef0fc2..c5698f9c7a33 100644
--- a/media-video/rtmpdump/rtmpdump-9999.ebuild
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -5,23 +5,23 @@ EAPI="7"
inherit multilib toolchain-funcs multilib-minimal flag-o-matic
-DESCRIPTION="RTMP client intended to stream audio or video flash content"
+DESCRIPTION="RTMP client, librtmp library intended to stream audio or video flash content"
HOMEPAGE="https://rtmpdump.mplayerhq.hu/"
# the library is LGPL-2.1, the command is GPL-2
-LICENSE="GPL-2 LGPL-2.1"
+LICENSE="LGPL-2.1 tools? ( GPL-2 )"
SLOT="0"
-IUSE="gnutls ssl static-libs libressl"
+IUSE="gnutls ssl static-libs +tools libressl"
+
+REQUIRED_USE="?? ( gnutls libressl )"
DEPEND="ssl? (
gnutls? (
>=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP},nettle(+)]
dev-libs/nettle:0=[${MULTILIB_USEDEP}]
)
- !gnutls? (
- !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ !gnutls? ( !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] ) )
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
)"
RDEPEND="${DEPEND}"
@@ -37,23 +37,20 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
- SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+ SRC_URI="http://git.ffmpeg.org/gitweb/rtmpdump.git/snapshot/c5f04a58fc2aeea6296ca7c44ee4734c18401aa3.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-c5f04a5"
fi
pkg_setup() {
- if ! use ssl && use gnutls ; then
- ewarn "USE='gnutls' is ignored without USE='ssl'."
- ewarn "Please review the local USE flags for this package."
- fi
-}
-
-src_unpack() {
- if [[ ${PV} == *9999 ]] ; then
- git-r3_src_unpack
- else
- mkdir -p "${S}" || die "Can't create source directory"
- cd "${S}" || die
- unpack ${A}
+ if ! use ssl; then
+ if use gnutls; then
+ ewarn "USE='gnutls' is ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+ if use libressl; then
+ ewarn "USE='libressl' is ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
fi
}
@@ -80,9 +77,7 @@ multilib_src_compile() {
crypto="OPENSSL"
fi
fi
- #fix multilib-script support. Bug #327449
- sed -i "/^libdir/s:lib$:$(get_libdir):" librtmp/Makefile || die
- if ! multilib_is_native_abi; then
+ if ! multilib_is_native_abi || ! use tools ; then
cd librtmp || die
fi
emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" \
@@ -91,13 +86,13 @@ multilib_src_compile() {
multilib_src_install() {
mkdir -p "${ED}"/usr/$(get_libdir) || die
- if multilib_is_native_abi; then
+ if multilib_is_native_abi && use tools ; then
dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
else
cd librtmp || die
fi
emake DESTDIR="${D}" prefix="${EPREFIX}/usr" mandir='$(prefix)/share/man' \
- CRYPTO="${crypto}" install
+ CRYPTO="${crypto}" libdir="${EPREFIX}/usr/$(get_libdir)" install
find "${D}" -name '*.la' -delete || die
use static-libs || find "${D}" -name '*.a' -delete || die
}