summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/rtmpdump')
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild9
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4_p20190330.ebuild15
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild12
3 files changed, 11 insertions, 25 deletions
diff --git a/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild b/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild
index a3b8a59caac3..fb6e6d60d9f0 100644
--- a/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild
+++ b/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -11,7 +11,7 @@ HOMEPAGE="https://rtmpdump.mplayerhq.hu/"
# the library is LGPL-2.1, the command is GPL-2
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="gnutls ssl static-libs libressl"
+IUSE="gnutls ssl static-libs"
DEPEND="ssl? (
gnutls? (
@@ -19,8 +19,7 @@ DEPEND="ssl? (
dev-libs/nettle:0=[${MULTILIB_USEDEP}]
)
!gnutls? (
- !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ dev-libs/openssl:0=[${MULTILIB_USEDEP}]
)
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
)"
@@ -67,7 +66,7 @@ src_prepare() {
-e 's:OPT:OPTS:' \
-e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
|| die "failed to fix Makefile"
- use ssl && use !gnutls && use !libressl && eapply "${FILESDIR}/${PN}-openssl-1.1-v2.patch"
+ use ssl && use !gnutls && eapply "${FILESDIR}/${PN}-openssl-1.1-v2.patch"
default
multilib_copy_sources
}
diff --git a/media-video/rtmpdump/rtmpdump-2.4_p20190330.ebuild b/media-video/rtmpdump/rtmpdump-2.4_p20190330.ebuild
index c5698f9c7a33..839b25613c0b 100644
--- a/media-video/rtmpdump/rtmpdump-2.4_p20190330.ebuild
+++ b/media-video/rtmpdump/rtmpdump-2.4_p20190330.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -11,17 +11,14 @@ HOMEPAGE="https://rtmpdump.mplayerhq.hu/"
# the library is LGPL-2.1, the command is GPL-2
LICENSE="LGPL-2.1 tools? ( GPL-2 )"
SLOT="0"
-IUSE="gnutls ssl static-libs +tools libressl"
-
-REQUIRED_USE="?? ( gnutls libressl )"
+IUSE="gnutls ssl static-libs +tools"
DEPEND="ssl? (
gnutls? (
>=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP},nettle(+)]
dev-libs/nettle:0=[${MULTILIB_USEDEP}]
)
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- !gnutls? ( !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] ) )
+ !gnutls? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
)"
RDEPEND="${DEPEND}"
@@ -47,10 +44,6 @@ pkg_setup() {
ewarn "USE='gnutls' is ignored without USE='ssl'."
ewarn "Please review the local USE flags for this package."
fi
- if use libressl; then
- ewarn "USE='libressl' is ignored without USE='ssl'."
- ewarn "Please review the local USE flags for this package."
- fi
fi
}
@@ -64,7 +57,7 @@ src_prepare() {
-e 's:OPT:OPTS:' \
-e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
|| die "failed to fix Makefile"
- use ssl && use !gnutls && use !libressl && eapply "${FILESDIR}/${PN}-openssl-1.1-v2.patch"
+ use ssl && use !gnutls && eapply "${FILESDIR}/${PN}-openssl-1.1-v2.patch"
default
multilib_copy_sources
}
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
index c5698f9c7a33..8e1443f8b835 100644
--- a/media-video/rtmpdump/rtmpdump-9999.ebuild
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -11,17 +11,15 @@ HOMEPAGE="https://rtmpdump.mplayerhq.hu/"
# the library is LGPL-2.1, the command is GPL-2
LICENSE="LGPL-2.1 tools? ( GPL-2 )"
SLOT="0"
-IUSE="gnutls ssl static-libs +tools libressl"
+IUSE="gnutls ssl static-libs +tools"
-REQUIRED_USE="?? ( gnutls libressl )"
DEPEND="ssl? (
gnutls? (
>=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP},nettle(+)]
dev-libs/nettle:0=[${MULTILIB_USEDEP}]
)
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- !gnutls? ( !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] ) )
+ !gnutls? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
)"
RDEPEND="${DEPEND}"
@@ -47,10 +45,6 @@ pkg_setup() {
ewarn "USE='gnutls' is ignored without USE='ssl'."
ewarn "Please review the local USE flags for this package."
fi
- if use libressl; then
- ewarn "USE='libressl' is ignored without USE='ssl'."
- ewarn "Please review the local USE flags for this package."
- fi
fi
}