summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/streamdvd/files')
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-gcc41.patch13
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-gcc43.patch44
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-gcc44.patch24
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-libdvdread.patch36
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-makefile.patch27
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4.patch22
6 files changed, 166 insertions, 0 deletions
diff --git a/media-video/streamdvd/files/streamdvd-0.4-gcc41.patch b/media-video/streamdvd/files/streamdvd-0.4-gcc41.patch
new file mode 100644
index 000000000000..2dbbd7117f3d
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-gcc41.patch
@@ -0,0 +1,13 @@
+Index: StreamDVD-0.4/mplex/zalphastrm.hpp
+===================================================================
+--- StreamDVD-0.4.orig/mplex/zalphastrm.hpp
++++ StreamDVD-0.4/mplex/zalphastrm.hpp
+@@ -45,7 +45,7 @@ protected:
+ virtual bool AUBufferNeedsRefill();
+ virtual void NextDTSPTS( clockticks &DTS, clockticks &PTS);
+ virtual void ScanFirstSeqHeader();
+- bool ZAlphaStream::RunOutComplete();
++ bool RunOutComplete();
+
+ private:
+ float z_min;
diff --git a/media-video/streamdvd/files/streamdvd-0.4-gcc43.patch b/media-video/streamdvd/files/streamdvd-0.4-gcc43.patch
new file mode 100644
index 000000000000..89e33f58db4b
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-gcc43.patch
@@ -0,0 +1,44 @@
+diff -aur mplex.old/inputstrm.cpp mplex/inputstrm.cpp
+--- mplex.old/inputstrm.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/inputstrm.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -23,6 +23,7 @@
+
+ #include "config.h"
+ #include <assert.h>
++#include <climits>
+
+ #include "mjpeg_types.h"
+ #include "fastintfns.h"
+diff -aur mplex.old/multiplexor.cpp mplex/multiplexor.cpp
+--- mplex.old/multiplexor.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/multiplexor.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -22,6 +22,7 @@
+ #include "config.h"
+ #include <math.h>
+ #include <stdlib.h>
++#include <cstring>
+
+ #include "mjpeg_types.h"
+ #include "mjpeg_logging.h"
+diff -aur mplex.old/padstrm.cpp mplex/padstrm.cpp
+--- mplex.old/padstrm.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/padstrm.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -25,6 +25,7 @@
+ #endif
+
+ #include "padstrm.hpp"
++#include <cstring>
+
+
+
+diff -aur mplex.old/zalphastrm_in.cpp mplex/zalphastrm_in.cpp
+--- mplex.old/zalphastrm_in.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/zalphastrm_in.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -23,6 +23,7 @@
+ #include "config.h"
+ #include <math.h>
+ #include <stdlib.h>
++#include <cstring>
+
+ #include "zalphastrm.hpp"
+ #include "interact.hpp"
diff --git a/media-video/streamdvd/files/streamdvd-0.4-gcc44.patch b/media-video/streamdvd/files/streamdvd-0.4-gcc44.patch
new file mode 100644
index 000000000000..2ca12ff29f69
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-gcc44.patch
@@ -0,0 +1,24 @@
+diff -ur StreamDVD-0.4.orig/mplex/lpcmstrm_in.cpp StreamDVD-0.4/mplex/lpcmstrm_in.cpp
+--- StreamDVD-0.4.orig/mplex/lpcmstrm_in.cpp 2004-03-09 00:10:53.000000000 +0200
++++ StreamDVD-0.4/mplex/lpcmstrm_in.cpp 2009-08-05 22:05:48.000000000 +0300
+@@ -52,7 +52,7 @@
+
+ bool LPCMStream::Probe(IBitStream &bs )
+ {
+- char *last_dot = strrchr( bs.StreamName(), '.' );
++ const char *last_dot = strrchr( bs.StreamName(), '.' );
+ return
+ last_dot != NULL
+ && strcmp( last_dot+1, "lpcm") == 0;
+diff -ur StreamDVD-0.4.orig/mplex/yuv4mpeg_ratio.c StreamDVD-0.4/mplex/yuv4mpeg_ratio.c
+--- StreamDVD-0.4.orig/mplex/yuv4mpeg_ratio.c 2004-03-09 00:10:53.000000000 +0200
++++ StreamDVD-0.4/mplex/yuv4mpeg_ratio.c 2009-08-05 22:07:49.000000000 +0300
+@@ -104,7 +104,7 @@
+
+ int y4m_parse_ratio(y4m_ratio_t *r, const char *s)
+ {
+- char *t = strchr(s, ':');
++ const char *t = strchr(s, ':');
+ if (t == NULL) return Y4M_ERR_RANGE;
+ r->n = atoi(s);
+ r->d = atoi(t+1);
diff --git a/media-video/streamdvd/files/streamdvd-0.4-libdvdread.patch b/media-video/streamdvd/files/streamdvd-0.4-libdvdread.patch
new file mode 100644
index 000000000000..b8f59ee54dba
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-libdvdread.patch
@@ -0,0 +1,36 @@
+diff -N -r -u StreamDVD-0.4/contrib/lsdvd/lsdvd.c new/contrib/lsdvd/lsdvd.c
+--- StreamDVD-0.4/contrib/lsdvd/lsdvd.c 2004-03-08 23:10:53.000000000 +0100
++++ new/contrib/lsdvd/lsdvd.c 2006-03-31 12:57:43.000000000 +0200
+@@ -14,6 +14,8 @@
+ * output info structures in form of a Perl module, by Henk Vergonet.
+ * 2004-02-25 now prints the stream-id's for audio and subpicture streams, by Reinhardt Wolf
+ */
++#define __STDC_LIMIT_MACROS
++#include <stdint.h>
+ #include <dvdread/ifo_read.h>
+ #include <string.h>
+ #include <sys/stat.h>
+diff -N -r -u StreamDVD-0.4/contrib/StreamAnalyze/streamanalyze.c new/contrib/StreamAnalyze/streamanalyze.c
+--- StreamDVD-0.4/contrib/StreamAnalyze/streamanalyze.c 2004-03-08 23:10:53.000000000 +0100
++++ new/contrib/StreamAnalyze/streamanalyze.c 2006-03-31 12:57:27.000000000 +0200
+@@ -19,6 +19,8 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <getopt.h>
++#define __STDC_LIMIT_MACROS
++#include <stdint.h>
+ #include <dvdread/ifo_read.h>
+ #include <dvdread/ifo_types.h>
+ #include <dvdread/dvd_reader.h>
+diff -N -r -u StreamDVD-0.4/streamdvd.c new/streamdvd.c
+--- StreamDVD-0.4/streamdvd.c 2004-03-08 23:10:53.000000000 +0100
++++ new/streamdvd.c 2006-03-31 12:50:45.000000000 +0200
+@@ -19,6 +19,8 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <getopt.h>
++#define __STDC_LIMIT_MACROS
++#include <stdint.h>
+ #include <dvdread/ifo_read.h>
+ #include <dvdread/ifo_types.h>
+ #include <dvdread/dvd_reader.h>
diff --git a/media-video/streamdvd/files/streamdvd-0.4-makefile.patch b/media-video/streamdvd/files/streamdvd-0.4-makefile.patch
new file mode 100644
index 000000000000..84608d80a689
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-makefile.patch
@@ -0,0 +1,27 @@
+Index: StreamDVD-0.4/Makefile
+===================================================================
+--- StreamDVD-0.4.orig/Makefile
++++ StreamDVD-0.4/Makefile
+@@ -1,16 +1,16 @@
+ INSTALLDIR = /usr/local/bin/
+
+ all:
+- g++ -g -Wall -ldvdread -lm -o streamdvd -I. -Implex streamdvd.c requant.c mplex/*.c mplex/*.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o streamdvd -I. -Implex streamdvd.c requant.c mplex/*.c mplex/*.cpp -ldvdread -lm
+
+ addon:
+- gcc -g -Wall -ldvdread -o streamanalyze contrib/StreamAnalyze/streamanalyze.c
+- gcc -g -Wall -ldvdread -DVERSION=\"0.9\" -o lsdvd contrib/lsdvd/lsdvd.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o streamanalyze contrib/StreamAnalyze/streamanalyze.c -ldvdread
++ $(CC) $(CFLAGS) $(LDFLAGS) -DVERSION=\"0.9\" -o lsdvd contrib/lsdvd/lsdvd.c -ldvdread
+
+ gui:
+- g++ -g -Wall -ldvdread -lm -o streamdvd -I. -Implex streamdvd.c requant.c mplex/*.c mplex/*.cpp
+- gcc -g -Wall -ldvdread -o streamanalyze contrib/StreamAnalyze/streamanalyze.c
+- gcc -g -Wall -ldvdread -DVERSION=\"0.9\" -o lsdvd contrib/lsdvd/lsdvd.c
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o streamdvd -I. -Implex streamdvd.c requant.c mplex/*.c mplex/*.cpp -ldvdread -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -o streamanalyze contrib/StreamAnalyze/streamanalyze.c -ldvdread
++ $(CC) $(CFLAGS) $(LDFLAGS) -DVERSION=\"0.9\" -o lsdvd contrib/lsdvd/lsdvd.c -ldvdread
+
+ clean:
+ rm -f streamdvd streamanalyze lsdvd
diff --git a/media-video/streamdvd/files/streamdvd-0.4.patch b/media-video/streamdvd/files/streamdvd-0.4.patch
new file mode 100644
index 000000000000..d078aa7059a3
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4.patch
@@ -0,0 +1,22 @@
+--- Gui/StreamDVD/Gui.pm.orig 2004-03-08 23:10:53.000000000 +0100
++++ Gui/StreamDVD/Gui.pm 2004-05-30 13:24:38.342490078 +0200
+@@ -18,7 +18,7 @@
+ use Tk::BrowseEntry;
+ use Tk::LabFrame;
+ use Tk::Photo;
+-use Tk::JPEG::Lite;
++use Tk::JPEG;
+ use StreamDVD::Defs;
+ use StreamDVD::Calc;
+ use strict;
+--- Gui/StreamDVD/Config.pm.orig 2004-03-08 23:10:53.000000000 +0100
++++ Gui/StreamDVD/Config.pm 2004-05-30 13:24:28.314195864 +0200
+@@ -284,7 +284,7 @@
+ $self->{MOUNT} = "/dvd";
+ $self->{TEMPDIR} = "/tmp";
+ $self->{DATADIR} = $ENV{HOME};
+- $self->{LSDVD} = "lsdvd";
++ $self->{LSDVD} = "lsdvd-streamdvd";
+ $self->{STREAMANALYZE} = "streamanalyze";
+ $self->{STREAMDVD} = "streamdvd";
+ $self->{DVDAUTHOR} = "dvdauthor";