summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/super_demux')
-rw-r--r--media-video/super_demux/super_demux-0.3-r1.ebuild26
-rw-r--r--media-video/super_demux/super_demux-0.3.ebuild16
2 files changed, 6 insertions, 36 deletions
diff --git a/media-video/super_demux/super_demux-0.3-r1.ebuild b/media-video/super_demux/super_demux-0.3-r1.ebuild
deleted file mode 100644
index 5e64d973faf2..000000000000
--- a/media-video/super_demux/super_demux-0.3-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="DVB transport stream TS to ES demultiplexer"
-HOMEPAGE="http://panteltje.com/panteltje/dvd/"
-SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-PATCHES=( "${FILESDIR}/${P}.diff" )
-
-src_compile() {
- append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
-}
-
-src_install() {
- dobin super_demux
- dodoc CHANGES README
-}
diff --git a/media-video/super_demux/super_demux-0.3.ebuild b/media-video/super_demux/super_demux-0.3.ebuild
index 9e79e39bedcb..c033ffc41c50 100644
--- a/media-video/super_demux/super_demux-0.3.ebuild
+++ b/media-video/super_demux/super_demux-0.3.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=7
-inherit eutils toolchain-funcs flag-o-matic
-
-IUSE=""
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="DVB transport stream TS to ES demultiplexer"
HOMEPAGE="http://panteltje.com/panteltje/dvd/"
@@ -15,13 +13,11 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-src_prepare() {
- epatch "${FILESDIR}/${P}.diff"
-}
+PATCHES=( "${FILESDIR}/${P}.diff" )
src_compile() {
- append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ append-cflags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install() {