summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/tivodecode/tivodecode-0.2_pre4.ebuild')
-rw-r--r--media-video/tivodecode/tivodecode-0.2_pre4.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/media-video/tivodecode/tivodecode-0.2_pre4.ebuild b/media-video/tivodecode/tivodecode-0.2_pre4.ebuild
index 511c7c80d240..3328d007ad23 100644
--- a/media-video/tivodecode/tivodecode-0.2_pre4.ebuild
+++ b/media-video/tivodecode/tivodecode-0.2_pre4.ebuild
@@ -1,16 +1,20 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit toolchain-funcs
MY_P=${P/_/}
DESCRIPTION="TiVo File Decoder"
-HOMEPAGE="http://tivodecode.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://tivodecode.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-S="${WORKDIR}/${MY_P}"
+src_compile(){
+ emake AR="$(tc-getAR)"
+}