summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/tivodecode')
-rw-r--r--media-video/tivodecode/Manifest1
-rw-r--r--media-video/tivodecode/metadata.xml12
-rw-r--r--media-video/tivodecode/tivodecode-0.2_pre4.ebuild25
3 files changed, 38 insertions, 0 deletions
diff --git a/media-video/tivodecode/Manifest b/media-video/tivodecode/Manifest
new file mode 100644
index 000000000000..93e98f0594ce
--- /dev/null
+++ b/media-video/tivodecode/Manifest
@@ -0,0 +1 @@
+DIST tivodecode-0.2pre4.tar.gz 124685 SHA256 788839cc4ad66f5b20792e166514411705e8564f9f050584c54c3f1f452e9cdf
diff --git a/media-video/tivodecode/metadata.xml b/media-video/tivodecode/metadata.xml
new file mode 100644
index 000000000000..a31d9764569d
--- /dev/null
+++ b/media-video/tivodecode/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">This software converts a .TiVo file (produced by the TiVoToGo functionality on recent TiVo software releases, or from files downloaded through the web interface) to a normal MPEG file.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tivodecode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/tivodecode/tivodecode-0.2_pre4.ebuild b/media-video/tivodecode/tivodecode-0.2_pre4.ebuild
new file mode 100644
index 000000000000..2a9ba00b3671
--- /dev/null
+++ b/media-video/tivodecode/tivodecode-0.2_pre4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator
+
+MY_PV="$(delete_version_separator '_')"
+
+DESCRIPTION="TiVo File Decoder"
+HOMEPAGE="http://tivodecode.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog
+}