summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vlc/vlc-3.0.9999.ebuild')
-rw-r--r--media-video/vlc/vlc-3.0.9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-video/vlc/vlc-3.0.9999.ebuild b/media-video/vlc/vlc-3.0.9999.ebuild
index 044aa2ff014a..f97e73f1b770 100644
--- a/media-video/vlc/vlc-3.0.9999.ebuild
+++ b/media-video/vlc/vlc-3.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -267,6 +267,10 @@ src_prepare() {
sed -i 's/ --started-from-file//' share/vlc.desktop.in || die
fi
+ # Disable running of vlc-cache-gen, we do that in pkg_postinst
+ sed -e "/test.*build.*host/s/\$(host)/nothanks/" \
+ -i Makefile.am -i bin/Makefile.am || die "Failed to disable vlc-cache-gen"
+
eautoreconf
# Disable automatic running of tests.
@@ -473,6 +477,10 @@ pkg_postinst() {
}
pkg_postrm() {
+ if [[ -e /usr/lib64/vlc/plugins/plugins.dat ]]; then
+ rm /usr/lib64/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
+ fi
+
gnome2_icon_cache_update
xdg_mimeinfo_database_update
xdg_desktop_database_update