summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/yle-dl')
-rw-r--r--media-video/yle-dl/Manifest3
-rw-r--r--media-video/yle-dl/metadata.xml3
-rw-r--r--media-video/yle-dl/yle-dl-20240130.ebuild (renamed from media-video/yle-dl/yle-dl-20210917.ebuild)19
-rw-r--r--media-video/yle-dl/yle-dl-20240429.ebuild57
4 files changed, 73 insertions, 9 deletions
diff --git a/media-video/yle-dl/Manifest b/media-video/yle-dl/Manifest
index c4e53a88f0f0..a67cb0a8f277 100644
--- a/media-video/yle-dl/Manifest
+++ b/media-video/yle-dl/Manifest
@@ -1 +1,2 @@
-DIST yle-dl-20210917.tar.gz 66746 BLAKE2B 91849a5d88615fc01f12ac19cd6c5bc3acf40548c5c024eff6141b6996d0b7b2c9363d1a2d2820cd61f99105fdd1bca835506ba199bf05d2a3b537dc88f41f10 SHA512 a26d4516f932561fe49da4a2c5e7dbc5eb65bcc4e5a7073f3636b70825c54fa9ba74feea55b3f6fcc538f4a300f99262eb4f26ba1e73efd56ff612a86971ac81
+DIST yle-dl-20240130.tar.gz 77787 BLAKE2B b0dd82813a3defb6305cd5b6529d5c5558a0c82d7c8ba9714e836b1d98a09bdad27882c975ca8a98b26a6188194157586fef882437c486bf4c7f480677fc386f SHA512 d803c6703987f4fbd787c608830398ff4081407349146d7fc98de2387f0313e6354b27b1c6d3de14a7a4bc7d44c30d05c63708cc7f780a7534e15f193f988138
+DIST yle-dl-20240429.tar.gz 78464 BLAKE2B d42eaf30bb93125c00007072c1c96fbadccc755bbac3bd11599b58a7b5aad2b1fc0ab06aadfb83a3c66155f7fe1d271f54ad929ea3047758b8719987b74800fa SHA512 73a0eedbfafe97ab9c9857c088d309462e70f916de78be0d2b5399cec8ad50bee5701f0748d07e92dc2c3dca2a73273f367948dd7dd571dd022bce68bcc5f010
diff --git a/media-video/yle-dl/metadata.xml b/media-video/yle-dl/metadata.xml
index 42361307323b..bbd655996511 100644
--- a/media-video/yle-dl/metadata.xml
+++ b/media-video/yle-dl/metadata.xml
@@ -6,4 +6,7 @@
<name>Joonas Niilola</name>
</maintainer>
<stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">aajanki/yle-dl</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-video/yle-dl/yle-dl-20210917.ebuild b/media-video/yle-dl/yle-dl-20240130.ebuild
index 1e5ecd0a0abd..d879b645e845 100644
--- a/media-video/yle-dl/yle-dl-20210917.ebuild
+++ b/media-video/yle-dl/yle-dl-20240130.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=flit
inherit distutils-r1 optfeature
DESCRIPTION="Download media files from Yle Areena"
HOMEPAGE="https://aajanki.github.io/yle-dl/ https://github.com/aajanki/yle-dl"
-SRC_URI="https://github.com/aajanki/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/aajanki/yle-dl/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 x86"
@@ -25,7 +26,7 @@ RESTRICT="test"
RDEPEND="media-video/ffmpeg
net-misc/wget
>=dev-python/attrs-18.1.0[${PYTHON_USEDEP}]
- >=dev-python/configargparse-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-0.13.0[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/progress[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]"
@@ -37,9 +38,9 @@ BDEPEND="test? (
dev-python/wheel[${PYTHON_USEDEP}]
)"
-distutils_enable_tests setup.py
+distutils_enable_tests pytest
-DOCS=( COPYING ChangeLog README.fi README.md yledl.conf.sample )
+DOCS=( COPYING ChangeLog README.fi.md README.sv.md README.md yledl.conf.sample )
src_install() {
docompress -x "/usr/share/doc/${PF}/yledl.conf.sample"
@@ -50,5 +51,7 @@ pkg_postinst() {
elog "Sample configuration file has been installed to "
elog " /usr/share/doc/yle-dl-${PVR}/yledl.conf.sample"
elog
- optfeature "youtube-dl download engine" net-misc/youtube-dl
+ optfeature "automatically detect filesystems that require restricted character sets" dev-python/psutil
+ optfeature "store metadata as extended file attributes" dev-python/pyxattr
+ optfeature "youtube-dl download engine" net-misc/yt-dlp
}
diff --git a/media-video/yle-dl/yle-dl-20240429.ebuild b/media-video/yle-dl/yle-dl-20240429.ebuild
new file mode 100644
index 000000000000..d879b645e845
--- /dev/null
+++ b/media-video/yle-dl/yle-dl-20240429.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=flit
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download media files from Yle Areena"
+HOMEPAGE="https://aajanki.github.io/yle-dl/ https://github.com/aajanki/yle-dl"
+SRC_URI="https://github.com/aajanki/yle-dl/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Requires an active internet connection during tests,
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="media-video/ffmpeg
+ net-misc/wget
+ >=dev-python/attrs-18.1.0[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-0.13.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/progress[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ ${RDEPEND}
+ media-video/ffmpeg[gnutls]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+DOCS=( COPYING ChangeLog README.fi.md README.sv.md README.md yledl.conf.sample )
+
+src_install() {
+ docompress -x "/usr/share/doc/${PF}/yledl.conf.sample"
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ elog "Sample configuration file has been installed to "
+ elog " /usr/share/doc/yle-dl-${PVR}/yledl.conf.sample"
+ elog
+ optfeature "automatically detect filesystems that require restricted character sets" dev-python/psutil
+ optfeature "store metadata as extended file attributes" dev-python/pyxattr
+ optfeature "youtube-dl download engine" net-misc/yt-dlp
+}