summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/apinger')
-rw-r--r--net-analyzer/apinger/apinger-0.4.1-r1.ebuild40
-rw-r--r--net-analyzer/apinger/files/apinger-0.4.1-fno-common.patch11
-rw-r--r--net-analyzer/apinger/files/apinger-0.4.1-stray-backslash.patch13
3 files changed, 64 insertions, 0 deletions
diff --git a/net-analyzer/apinger/apinger-0.4.1-r1.ebuild b/net-analyzer/apinger/apinger-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..9126a208502a
--- /dev/null
+++ b/net-analyzer/apinger/apinger-0.4.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Alarm Pinger"
+HOMEPAGE="https://github.com/Jajcus/apinger/"
+SRC_URI="https://github.com/Jajcus/apinger/archive/${PN^^}_${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ sys-devel/flex
+ virtual/yacc
+"
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.1-fno-common.patch
+ "${FILESDIR}"/${PN}-0.4.1-stray-backslash.patch
+)
+S="${WORKDIR}/${PN}-${PN^^}_${PV//./_}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake -C src/ cfgparser1.h
+ default
+}
+
+src_install() {
+ default
+ insinto /etc
+ doins src/${PN}.conf
+}
diff --git a/net-analyzer/apinger/files/apinger-0.4.1-fno-common.patch b/net-analyzer/apinger/files/apinger-0.4.1-fno-common.patch
new file mode 100644
index 000000000000..d74dc1c66f27
--- /dev/null
+++ b/net-analyzer/apinger/files/apinger-0.4.1-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/src/apinger.h
++++ b/src/apinger.h
+@@ -99,7 +99,7 @@
+ void *target_id;
+ };
+
+-struct target *targets;
++extern struct target *targets;
+
+ extern int foreground;
+ extern char *config_file;
diff --git a/net-analyzer/apinger/files/apinger-0.4.1-stray-backslash.patch b/net-analyzer/apinger/files/apinger-0.4.1-stray-backslash.patch
new file mode 100644
index 000000000000..61db76fb9232
--- /dev/null
+++ b/net-analyzer/apinger/files/apinger-0.4.1-stray-backslash.patch
@@ -0,0 +1,13 @@
+--- acinclude.m4
++++ b/acinclude.m4
+@@ -39,8 +39,8 @@
+ [$jk_inet_includes
+ $jk_icmp_includes])
+
+-AC_CHECK_MEMBERS([struct icmp.icmp_type, struct icmp.icmp_code,\
+-struct icmp.icmp_cksum, struct icmp.icmp_seq,\
++AC_CHECK_MEMBERS([struct icmp.icmp_type, struct icmp.icmp_code,
++struct icmp.icmp_cksum, struct icmp.icmp_seq,
+ struct icmp.icmp_id],[],
+ AC_MSG_ERROR(struct icmp not defined or not compatible),
+ [$jk_inet_includes